Closed Bug 1333769 Opened 3 years ago Closed 3 years ago

Nightly l10n repacks generate wrong complete MARs

Categories

(Release Engineering :: General, defect)

defect
Not set

Tracking

(firefox53 fixed)

RESOLVED FIXED
Tracking Status
firefox53 --- fixed

People

(Reporter: rail, Assigned: Callek)

Details

Attachments

(2 files)

pascalc reported in IRC that he failed to update his nightly:

AUS:SVC Downloader:onStopRequest - original URI spec: https://mozilla-nightly-updates.s3.amazonaws.com/mozilla-central/20170125110119/Firefox-mozilla-central-54.0a1-linux64-fr.complete.mar?versionId=L.HbmS22RQFAIcg2CUsuimsMDLcvsmOl, final URI spec: https://mozilla-nightly-updates.s3.amazonaws.com/mozilla-central/20170125110119/Firefox-mozilla-central-54.0a1-linux64-fr.complete.mar?versionId=L.HbmS22RQFAIcg2CUsuimsMDLcvsmOl, status: 0
AUS:SVC Downloader:onStopRequest - status: 0, current fail: 0, max fail: 10, retryTimeout: 2000
AUS:SVC Downloader:_verifyDownload called
AUS:SVC Downloader:_verifyDownload downloaded size == expected size.
AUS:SVC Downloader:onStopRequest - setting state to: pending
AUS:SVC Downloader:onStopRequest - attempting to stage update: Nightly 54.0a1
AUS:SVC readStatusFile - status: failed: 23, path: /home/pascalc/applis/fxtrunk/updates/0/update.status
AUS:SVC handleFallbackToCompleteUpdate - install of complete or only one patch offered failed.
AUS:SVC UpdateManager:refreshUpdateStatus - Notifying observers that the update was staged. state: failed, status: failed: 23 


bhearsum> https://github.com/mozilla/gecko-dev/blob/master/toolkit/mozapps/update/common/errors.h#L42
bhearsum> #define VERSION_DOWNGRADE_ERROR 23


It turns out that we download the mar binary from http://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-central/mar-tools/ and they are out of date. 

https://dxr.mozilla.org/mozilla-central/source/tools/update-packaging/make_full_update.sh#110 is used to generate this and it doesn't explicitly pass the version.
we can probably use something like https://dxr.mozilla.org/mozilla-central/source/tools/update-packaging/make_incremental_update.sh#310-313 to explicitly pass the version.
Assignee: nobody → bugspam.Callek
Comment on attachment 8830353 [details]
Bug 1333769 - Explicitly pass the version to MAR.

https://reviewboard.mozilla.org/r/107176/#review108292
Attachment #8830353 - Flags: review?(rail) → review+
Comment on attachment 8830352 [details]
Bug 1333769 - Pass a MAR url to l10n tasks in taskcluster.

https://reviewboard.mozilla.org/r/107174/#review108308

should just work :)
Attachment #8830352 - Flags: review?(jlund) → review+
Comment on attachment 8830353 [details]
Bug 1333769 - Explicitly pass the version to MAR.

Approval Request Comment
[User impact if declined]: Complete mar's will fail to apply

[Has the fix been verified in Nightly?]: about to be
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: minimal
[Why is the change risky/not risky?]: mostly affects taskgraph selection of a binary used for l10n, also adds an explicit version flag to the mar generation
[String changes made/needed]: none
Attachment #8830353 - Flags: approval-mozilla-aurora?
Pushed by Callek@gmail.com:
https://hg.mozilla.org/mozilla-central/rev/a218f98a2c0d
Pass a MAR url to l10n tasks in taskcluster. r=jlund
https://hg.mozilla.org/mozilla-central/rev/24d9eb148461
Explicitly pass the version to MAR. r=rail a=philor for landing on central
Comment on attachment 8830353 [details]
Bug 1333769 - Explicitly pass the version to MAR.

Releng needs this, Aurora53+
Attachment #8830353 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.