Showing Windows 7-era loading spinner inside Taskbar Preview on Windows 10

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
9 months ago
7 months ago

People

(Reporter: mconley, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 8830434 [details]
Example of the spinner in question

A user approached me on IRC and told me that when using the Taskbar Preview feature for Firefox, that Windows shows an old-style (Windows 7-era) spinner while the thumbnail is loading.

I've attached a screenshot of an example spinner - though the user didn't actually capture that on their machine (the spinner goes away too quickly to easily capture a screenshot), it's just an example of the kind of spinner they're talking about.

Comment 1

9 months ago
Maybe this bug should go under layout or graphics?

Comment 2

8 months ago
This spinner is displayed twice by this preview, once as shown in the attachment, and a second time when you switch between the different tabs, when they're loading.
Is this actually our spinner and not just Win10 not having updated it? Especially if the spinner does, in fact, spin, I'd be surprised if it was us doing that... Felipe, do you know?
Flags: needinfo?(felipc)
Yeah, this is the OS spinner.. It shows up while the OS requests us a screenshot of the page, until we give it back  (and also when you hover the mouse over one preview and the OS requests a full render of the window as if that tab is selected).  Needless to say, this was never too fast and the spinner is expected to show up.
Flags: needinfo?(felipc)
Then I don't think there's anything we can do to tell win10 to use a more-win10-looking spinner...
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.