Closed Bug 1333921 Opened 3 years ago Closed 3 years ago

Taskcluster Android l10n nightlies broken due to missing API key

Categories

(Firefox Build System :: General, defect, critical)

Unspecified
Android
defect
Not set
critical

Tracking

(firefox53+ fixed, firefox54+ fixed)

RESOLVED FIXED
Tracking Status
firefox53 + fixed
firefox54 + fixed

People

(Reporter: RyanVM, Unassigned)

References

Details

Attachments

(1 file)

Fallout from bug 1256730?

https://treeherder.mozilla.org/logviewer.html#?job_id=71989051&repo=mozilla-aurora

INFO  -  checking for the Mozilla API key... no
INFO  -  ERROR: '/builds/mozilla-fennec-geoloc-api.key': No such file or directory.
INFO  -  *** Fix above errors and then restart with\
INFO  -                 "make -f client.mk build"
INFO  -  client.mk:379: recipe for target 'configure' failed
INFO  -  make: *** [configure] Error 1
ERROR - Return code: 2
FATAL - Configure failed!
FATAL - Running post_fatal callback...
FATAL - Exiting -1
INFO  - [mozharness: 2017-01-25 19:34:16.705621Z] Finished setup step (failed)
[Tracking Requested - why for this release]: Android l10n nightlies broken
Tracking 53/54+ for this bustage.
Duplicate of this bug: 1334090
This is a regression from bug 1256730.
glandium, gps does this affect also release or beta l10n builds ?
Flags: needinfo?(mh+mozilla)
Flags: needinfo?(gps)
To be explicit, this shouldn't (currently) affect beta/release. But that is because they are buildbot based and those keys should already be on those builders.

This also doesn't actually affect aurora/central *because* the taskcluster android builds don't actually regenerate anything that uses these keys, they take the stuff from the en-US builds instead.

That said, the presence of these keyfiles in the mozconfig does cause an error and shouldn't error. But we certainly want the error if they are missing in en-US
Blocks: 1256730
I did a taskcluster run of this code, just to verify that it would work:

https://tools.taskcluster.net/task-inspector/#GOOY2mZpQLmaq2TQRkRARw/

(That job was manually created from try-push code. I did not set any upload paths, so despite there being no artifacts from the repacks, they did complete successfully and are moved into place per the log)
Flags: needinfo?(mh+mozilla)
Flags: needinfo?(gps)
Comment on attachment 8830732 [details]
Bug 1333921 - Taskcluster Android l10n nightlies broken due to missing API key.

https://reviewboard.mozilla.org/r/107466/#review108598
Attachment #8830732 - Flags: review?(mshal) → review+
Pushed by Callek@gmail.com:
https://hg.mozilla.org/mozilla-central/rev/d92fd6b6d6bf
Taskcluster Android l10n nightlies broken due to missing API key. r=mshal a=bustage
Pushed by wmccloskey@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/81e8ac03d230
Taskcluster Android l10n nightlies broken due to missing API key. r=mshal a=bustage
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.