Closed Bug 1334002 Opened 4 years ago Closed 4 years ago

After the Flood crashes FF51 release browser on OSX

Categories

(Core :: Canvas: WebGL, defect)

51 Branch
x86_64
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1333534

People

(Reporter: jib, Unassigned)

References

()

Details

(Keywords: csectype-nullptr)

I restarted Firefox to upgrade to FF51 and was excited to try the "After the Flood" demo. Browser crashes before it starts every time.

STR: Open URL.

Actual result: After the shader compilation phase when the progress display says "initializing", the browser vanishes and crash reporter appears.

See bp-f2d98674-a3be-482d-bc44-0d21f2170126

EXC_BAD_ACCESS
not a sec issue IMHO
Happens even in a clean profile. Here's my gfx hardware:

Name: Firefox
Version: 51.0
Build ID: 20170118123726
Update Channel: release
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:51.0) Gecko/20100101 Firefox/51.0
OS: Darwin 15.6.0

Graphics
--------

Features
Compositing: OpenGL
Asynchronous Pan/Zoom: none
WebGL Renderer: NVIDIA Corporation -- NVIDIA GeForce GT 650M OpenGL Engine
WebGL2 Renderer: NVIDIA Corporation -- NVIDIA GeForce GT 650M OpenGL Engine
Hardware H264 Decoding: Yes
Audio Backend: audiounit
GPU #1
Active: Yes
Vendor ID: 0x8086
Device ID: 0x0166

Diagnostics
AzureCanvasAccelerated: 1
AzureCanvasBackend: skia
AzureContentBackend: skia
AzureFallbackCanvasBackend: none
TileHeight: 1024
TileWidth: 1024
Milan: High profile demo is crashing some macs
Flags: needinfo?(milan)
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(milan)
Resolution: --- → DUPLICATE
Duplicate of bug: 1333534
Group: core-security
You need to log in before you can comment on or make changes to this bug.