Closed Bug 1334070 Opened 3 years ago Closed 3 years ago

Link Dialog (Mac OS X: called "Sheet") too small

Categories

(Thunderbird :: Message Compose Window, defect)

45 Branch
x86_64
macOS
defect
Not set

Tracking

(thunderbird52 fixed, thunderbird53 fixed, thunderbird54 fixed)

RESOLVED FIXED
Thunderbird 54.0
Tracking Status
thunderbird52 --- fixed
thunderbird53 --- fixed
thunderbird54 --- fixed

People

(Reporter: Roman.Gebath, Assigned: Paenglab)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.95 Safari/537.36

Steps to reproduce:

Mac OS X specific (El Capitan). Thunderbird Version 45.7.0 (i hope the branch is correct, I’m not a developer)

It’s easily reproducable. When I try to add a Link using the according Toolbar-Item the window that opens (Mac Os X’s "Sheet") is too small.


Actual results:

The window is way to small, so one can’t work with it. See attached screenshot.


Expected results:

The windows (sheets) size should be large enough, to not crop the content.
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86_64
Here it is correct, but it's only a Mac without Retina.

Roman, what is your setup? Do you have a retina Mac with a external non-Retina Display? If yes where is the main window and where the Composer window?
I've already seen other reports with similar effects but can't find them now.
Oooh, I see. You’re exactly right, it’s an iMac in my office, and I have a second non-retina Display attached, on which I use Thunderbird. I can’t test it right now, because I’m at home, but tomorrow I will check if the problem is reproducable if I use Thunderbird on my main screen.
I can confirm the assumption. It works perfectly on the retina screen. Is this problem fixable?
Is there a difference when TB starts on Retina screen and then moves to the external screen or if it starts directly on external screen?

Can you also check what happens when you open the dialog in Compose window when it's on Retina and non-retina with both start cases from above?

Can you check following matrix?
Start TB on Retina/stay on Retina/open Composer on Retina             OK
Start TB on Retina/stay on Retina/open Composer on Non-Retina         OK/NOK
Start TB on Retina/move to Non-Retina/open Composer on Retina         OK/NOK
Start TB on Retina/stay on Retina/open Composer on Non-Retina         OK/NOK
Start TB on Non-Retina/stay on Non-Retina/open Composer on Retina     OK/NOK
Start TB on Non-Retina/stay on Non-Retina/open Composer on Non-Retina OK/NOK
Start TB on Non-Retina/move to Retina/open Composer on Retina         OK/NOK
Start TB on Non-Retina/move to Retina/open Composer on Non-Retina     OK/NOK
Start TB on Retina/stay on Retina/open Composer on Retina             OK
Start TB on Retina/stay on Retina/open Composer on Non-Retina         NOK
Start TB on Retina/move to Non-Retina/open Composer on Retina         NOK
Start TB on Retina/stay on Retina/open Composer on Non-Retina         NOK
Start TB on Non-Retina/stay on Non-Retina/open Composer on Retina     OK
Start TB on Non-Retina/stay on Non-Retina/open Composer on Non-Retina NOK
Start TB on Non-Retina/move to Retina/open Composer on Retina         OK
Start TB on Non-Retina/move to Retina/open Composer on Non-Retina     NOK

So it really doesn’t matter, as soon as the Composer Window is on Non-Retina, it is affected. Also if I move the Composer around, it’s okay on the Retina, and not okay on the Non-Retina. 

What may be of interest: If I move the window from one screen to the other with the Sheet (dialog) open, it stays the same "size". So if I open it on Non-Retina (state NOK) and move it with the open sheet on the Retina Screen, the it stays NOK. And also the other way round if I open the dialog on Retina (OK) and move it to Non-Retina, it stays OK, although it then is on a Non-Retina-Screen. So the affected code has to be the dialog-opening part. I guess TB calculates the size of the dialog-box by itself, but if it is already open and moved to the other screen, then the system (window manager?) makes the calculations of the running dialog and draws it correctly – paying attention to the retina/non-retina diffrences. I hope it is understandable what I mean (non-native speaker). If not, please ask.
Aleth, what do you think what can we do? As I know FX uses this dialogs no more and so it's very unlikely it will be fixed in toolkit.
Flags: needinfo?(aleth)
I forgot to check all the dialogs in the Message Composer Window. The only other dialog where this happens is the "Grafik" Dialog (I have a german version and it seems I can’t change the language. Could be "Graphic" or "Image"). It’s the item after "Anker" (I guess this one should be the same in english). 
Only on these two dialogs (Link and Graphic/Image) the problem appears. All the other dialogs seem to work, although they’re also Sheets. Could this be some kind of layout in the dialog? 

These are working dialogs of the same type: Anker, Table and spell-checking.
Isn't this just a modal dialog? Firefox certainly still uses them, e.g. for the master password query, and the size is OK there.
Flags: needinfo?(aleth)
Roman, please could you check if the dialog which opens when you click on the "Erweitert..." button has the same problem? On some dialogs you have to first fill something in them to activate the button.
I’m sorry I can’t find any "Erweitert..." button. Where should it be?

The soonest I can check this on the retina-non-retina setup is monday, because it’s my office’s computer, and I don’t have such setup at home.
When you open the "Link" dialog, on bottom right is the "Erweitert..." button. You have to fill both textfields to make it active. This button is in all this "Einfügen" dialogs.

No problem when you test it on Monday, the builds are actually busted and I can't create test builds.
Ah, I found it. I searched only the entire Composer Window, but not in the dialog. 
Okay, I will test it monday. Thanks for your support so far :D
Weeell, i forgot: I literally CAN’T test this, because due to the bug the dialog is so small, that the "Erweitert" Button is cropped. I also can’t reach it with the Keyboard, because the Tab Key just switches between the two text-inputs.
There exists a setting in macOS to enable tabbing to all elements. Can't say where it is as I'm not near a Mac.

You could also try to open it with a accesskey (in English it's "e").
Thanks, I’ve found it. Surprisingly the "Erweitert" dialog works fine!
Roman, thank you for the tests. Unfortunately we can't build macOS builds with changes I hope could fix this issue. We have to wait until this works again. When we can build again, I'll create a try build and inform you for testing it.
Thank you so much for your efforts!
Daily builds works fine. The popup menu which allows to insert a link into the message body is working as expected. Non-retina Mac. macOS 10.12
It works! 
If you open the dialogs on a non-retina display you can see the wrong layout for a blink, but it resets to the correct layout instantaneausly. So whatever code you’ve written works :)
Thank you :D
Thank you Roman for the testing. Then I'll attach the patch this evening and ask for review. Hopefully we can land it in TB 52.
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(Roman.Gebath)
Yes, but it will have to wait until TB 52.1 in April or I get in trouble for rushing a patch through.
Thank you all for your voluntary work :D
Attached patch bug1334070.patchSplinter Review
Jörg, according to Roman this fixes the issue.
Attachment #8841246 - Flags: review?(jorgk)
Yes, I know. I've already seen the changes on try. Can you please explain them.
It seems, only my understanding, not sure it's correct, when in <dialog> is button="accept,cancel" defined, then the dialog opens with a fixed button-box in LowRes dimensions and blocking repainting/resizing in HighRes. Without this definition the button-box stays dynamic.

I found this through comparing the dialogs with the issue with dialogs without. Checked on Windows and macOS that it doesn't regress on normal screens.
Comment on attachment 8841246 [details] [diff] [review]
bug1334070.patch

Fine, thanks. That's all the dialogs which need to be fixed, I assume.

Since the TB 52 beta 4 build failed, I'll include it there to improve the user experience of Mac users.
Attachment #8841246 - Flags: review?(jorgk)
Attachment #8841246 - Flags: review+
Attachment #8841246 - Flags: approval-comm-beta+
Attachment #8841246 - Flags: approval-comm-aurora+
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/63e348c30e234cce9f07acd76eacf99896ea47fb
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 54.0
You need to log in before you can comment on or make changes to this bug.