Blank page of https://fritz.box:<portnumber>

RESOLVED INVALID

Status

()

Firefox for Android
General
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: Dr. Werner Fink, Unassigned)

Tracking

50 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161212000000

Steps to reproduce:

Connect within LAN, a 192.168 area, the local route by using the URL https://fritz.box with a special port number.  This works with firefox 50.1.0 on x86_64 Linux by accepting the self signed certificate.  This certificate helps me to have a secure access from WAN, that is outside from the 192.168 area.

With firefox 50.1.0 I see a blank page.  How can I access my router from my Android devices again?


Actual results:

Blank page on  https://fritz.box with a special port number.


Expected results:

Show the web page of my fritz box with the URL https://fritz.box with a special port number. If required allow me to add an exception for.
(Reporter)

Updated

a year ago
OS: Unspecified → Android
Hardware: Unspecified → ARM
(Reporter)

Updated

a year ago
Has Regression Range: --- → yes
Please try this
* open a new private browsing tab 
* check request desktop site from the 3 dot menu
* visit the box

If this works then then it is a bug in the server. It may be sending webkit specific code to Firefox for Android.
Has Regression Range: yes → ---
Flags: needinfo?(werner)
(Reporter)

Comment 2

a year ago
Just had done some debugging and found that the noscript (for mobile https://noscript.net/nsa/) does cause this. That is very annoying as older firefox version had worked together with noscript. And a web browser without control over the scripts (java/javascript) from remote as well as possible cross scripting is not what I want.

IMHO plugins like noscript in its mobile version should work even on the mobile version of firefox
Flags: needinfo?(werner)
(Reporter)

Updated

a year ago
Component: General → Plugins
If this only happens with NSA then this bug is not a Firefox issue. You can report the bug to them in their forums at https://forums.informaction.com/viewforum.php?f=25
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Component: Plugins → General
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.