Closed Bug 1334175 Opened 3 years ago Closed 2 years ago

[AS] Add ability to edit top sites titles

Categories

(Firefox for Android :: Activity Stream, defect, P2)

ARM
Android
defect

Tracking

()

RESOLVED DUPLICATE of bug 1320803
Tracking Status
fennec + ---
firefox54 --- affected

People

(Reporter: liuche, Unassigned)

References

Details

(Whiteboard: [MobileAS])

As part of pinning, there used to be the capability to edit+pin so you can select the site you want to pin (rather than be limited to pinning sites that appear in top sites). Pinning also used to pin to a specific tile (rather than bumping the pin to the front).

This seems to have disappeared from the current version of AS. (I've personally found "just pinning" to be not very useful - if the site is already in my top sites list, there's no need to pin it. Perhaps Edit/Pin could be combined into a single feature.)
Due to A-S's design (a single, scrollable row of top sites), we've specifically decided against "pinning to a tile", and just displaying pins at the front. I've been finding it very useful personally; there are sites which will never make it into my Top Sites that I nevertheless would like to have very quick access to for a period of time, and have them "on top of mind" so to speak.

I agree that _what_ you can currently pin is a limited list, unfortunately - this feature didn't receive a ton of UX love yet. Currently "pinnable" is anything you see on the A-S panel, so Top Sites and Highlights. I'll be more content if I can just pin any website from my full history panel, for example. "Classic top sites" edit behaviour could also work, if we can figure out how to bridge the UX gap between "pin to top of list" and "pin to a tile".

Adding UX to the discussion.

P.S.: we have telemetry in place to measure usage of this feature (adding pins, removing pins, interacting with pins).
Flags: needinfo?(bbell)
Manual Pinning Top-Sites is a compelling feature that needs to be supported ASAP. We should also let people edit existing Top-Sites because the algorithm is never going to be perfect. Manually editing names and URL also helps combat problems where two different pages from the same sites could look the same as each other in Top-Sites.
Flags: needinfo?(bbell)
tracking-fennec: --- → ?
Whiteboard: [MobileAS]
From another version of this bug, we should prioritize this:

(In reply to bbell from bug 1394534 comment #2)
> At least, as high as the tablet work. The tablet work shouldn't be daunting
> since it only entails widening the current view, so maybe we can do both.
This was something users were able to do before and it'd solve a lot of de-dupe sites problems.

Bryan, can you give us some mocks on how this might work?
Rank: 1
Flags: needinfo?(bbell)
Priority: -- → P3
tracking-fennec: ? → ---
Spoke with Bryan on Vidyo: we can break this into two parts:

1) Long press -> Edit will allow a user to override the title of an existing top site (I'm thinking we have a map of url -> overridden title in sharedPrefs and don't bother with the complexities of browser DB titles).

2) We add text and button to ^ dialog, "Did you want to add a completely new pinned site instead? [Yes]". This will let a user add a url and add a custom top site into the pinned section – afaik, we can add a pinned item (it's a bookmark with parent == pinned, if I'm not mistaken) without having to worry about "How many times was this visited?" and how that will affect how it is sorted since pinned sites are deterministically sorted everytime anyway. IDEALLY, we resurrect the old top site edit dialog – the awesomebar search – for this. But if not, it could be a manual url entry.

We came to this solution based on hashing out ideas and how easy I felt they would be to implement, given my understanding of the code. To me, this doesn't seem too bad and doable for 57 provided the other work doesn't take a ridiculous amount of time.

Wireframe/mocks to follow: leaving NI. They shouldn't be super necessary for 1) ^, however.

---

Bryan thinks this is really important and we've fixed a bunch of bugs so I'll reflag for triage to resurface it.
tracking-fennec: --- → ?
tracking-fennec: ? → +
We're going to split it up into edit & add custom. Edit is P1 and custom is P2 rank 2.
Iteration: --- → 1.30
Rank: 1
Priority: P3 → P1
Summary: [AS] Can't edit+pin Top Sites → [AS] Add ability to edit top sites titles
Rank: 2
Since we ended up implementing bug 1398834 instead, bbell doesn't feel this is as important anymore (via slack):

> I think we’re fine without it. for now. people can delete ones they don’t like, and pin ones they do."
No longer blocks: 1398834
Flags: needinfo?(bbell)
Rank: 2 → 3
Priority: P1 → P2
[eng triage recommendation] P3.
[triage] Keeping the rank. It's big (especially if we take a step back and realize that editing titles and adding custom sites is a larger UX issue) and risky but it'd be nice to have.
All open Activity Stream bugs are moving from the whiteboard tag, "[mobileAS]", to the Firefox for Android component, "Activity Stream", so that I can keep better track of these bugs as the new triage owner; I will send out an email shortly with additional details, caveats, etc.
Component: Awesomescreen → Activity Stream
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1320803
You need to log in before you can comment on or make changes to this bug.