Closed Bug 1334249 Opened 5 years ago Closed 3 years ago

When "search for text when I start typing" is selected, and you are in responsive design mode, keyboard input into input fields redirects to the "find on this page" search

Categories

(DevTools :: Responsive Design Mode, defect, P3)

52 Branch
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1322385

People

(Reporter: jstyons, Assigned: miker)

References

Details

(Whiteboard: [rdm-v2])

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170123004004

Steps to reproduce:

1 - Turn on the "search for text when I start typing" option
2 - Visit a page with a text input (such as www.google.com)
3 - Type into the text input box


Actual results:

Keyboard input was redirected to the "find as I type" bar at the bottom of the screen


Expected results:

Keyboard input should have been directed to the input on the web page.
Status: UNCONFIRMED → NEW
Has STR: --- → yes
Component: Untriaged → Developer Tools: Responsive Design Mode
Ever confirmed: true
Hopefully the title made this clear, but there should be an additional step before the others I listed:

0 - Enter "responsive design mode" using the F12 debugger tools
It may not be related but I have the same problem with the Quick Find hotkeys (/) and ('). They both open the quick search bar when pressed instead of being typed.

This also happens when the "search for text when I start typing" option is disabled.
Thanks for the report!  I can reproduce the issue here.
Priority: -- → P3
Whiteboard: [rdm-v2]
(In reply to romlig from comment #2)
> It may not be related but I have the same problem with the Quick Find
> hotkeys (/) and ('). They both open the quick search bar when pressed
> instead of being typed.
> 
> This also happens when the "search for text when I start typing" option is
> disabled.

This part seems like a separate issue, I believe it's covered by bug 1317323.
Spotted the same issue on FF Developer 57.0b8 (64-bit) on Ubuntu 17.10
Product: Firefox → DevTools
Assignee: nobody → mratcliffe
Status: NEW → RESOLVED
Closed: 3 years ago
OS: Unspecified → All
Hardware: Unspecified → All
Resolution: --- → DUPLICATE
Duplicate of bug: 1322385
Duplicate of this bug: 1513785
You need to log in before you can comment on or make changes to this bug.