js/src/old-configure reports "grep: invalid option" on Windows

RESOLVED FIXED in Firefox 54

Status

()

--
trivial
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: tcampbell, Assigned: tcampbell)

Tracking

Trunk
mozilla54
x86
Windows
Points:
---

Firefox Tracking Flags

(firefox54 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

2 years ago
When building jsshell on Windows using mozilla-build 32-bit environment, the configure process has the following error message:

<<<
checking for _getc_nolock... (cached) yes
checking for sb-conf... no
checking for ve... no
checking for X... (cached) no
grep: invalid option -- /
Usage: grep [OPTION]... PATTERN [FILE]...
Try `grep --help' for more information.
grep: invalid option -- /
Usage: grep [OPTION]... PATTERN [FILE]...
Try `grep --help' for more information.
checking for valid debug flags... yes
checking NSPR selection... source-tree
checking what kind of list files are supported by the linker... list
>>>

This is caused by autoconf quoting problems, and a fix is attached.

Even with the error, the result for a default config is the same. Problems might have occurred if manually specifying -arch flag.
(Assignee)

Comment 1

2 years ago
Assignee: nobody → tcampbell
Attachment #8830920 - Flags: review?(mh+mozilla)
Comment on attachment 8830920 [details] [diff] [review]
0001-Bug-1334268-Fix-regex-escaping-in-js-src-old-configu.patch

Review of attachment 8830920 [details] [diff] [review]:
-----------------------------------------------------------------

The same change is needed in top-level old-configure.in.
Attachment #8830920 - Flags: review?(mh+mozilla)
(Assignee)

Comment 4

2 years ago
Attachment #8830920 - Attachment is obsolete: true
Attachment #8833174 - Flags: review?(mh+mozilla)
Attachment #8833174 - Flags: review?(mh+mozilla) → review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Comment 5

2 years ago
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/00f1ed73cf65
Fix regex escaping in js/src/old-configure. r=glandium
Keywords: checkin-needed

Comment 6

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/00f1ed73cf65
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox54: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
Duplicate of this bug: 1288849
You need to log in before you can comment on or make changes to this bug.