multipart/form-data with more than 100 hidden fields hangs while posting via v0.9.9

VERIFIED DUPLICATE of bug 130301

Status

()

Core
HTML: Form Submission
VERIFIED DUPLICATE of bug 130301
16 years ago
16 years ago

People

(Reporter: mozilla, Assigned: Alexandru Savulov)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
If you create a form with more than 100 hidden fields, and try to post using
multipart/form-data, the browser will hang while posting.  This behavior is only
seen in 0.9.9.  0.9.8 works just fine. 

I've been using PHP to generate the tests, but there is no reason that straight
HTML and CGIs will also exhibit this same behavior.  Note the difference between 

http://slacy.com/moztest.php?n=10 

and

http://slacy.com/moztest.php?n=110

The first works, and the second hangs the browser. 

Here is the source of "moztest.php"

<html><body>Heres the start of my form: 
<form enctype="multipart/form-data" action=mozecho.php method="post">
<?php
for ($i = 0; $i < $n; $i++) {
    print "<input type=hidden name=hide_$i value=$i>\n"; 
}
print "<input type=hidden name=count value=$i>\n"; 
?>
<input type=submit value="Score The Test">
</form>
<?php print "Form has $i hidden fields<br>\n";  ?>
</body></html>

Here is the source of "mozecho.php"

<html><body><?php
for ($i = 0; $i < $count; $i++) {
$varname = "hide_$i";
$value = ${$varname};
print "Hidden $i: Value $value<br>\n"; 
}
?>
</body></html>
(Assignee)

Comment 1

16 years ago
hmmm, souds more like the large data amount submission failure on linux. see bug
130301
(Assignee)

Updated

16 years ago
Depends on: 130301
(Reporter)

Comment 2

16 years ago
It sounded to me like bug 130301 is for regular POST methods.  I've found that
this problem only occurs with multipart/form-data, but that may just be that my
data was always under the "size limit" implied by bug 130301, and the
multipart/form-data encoding puts it over that limit.

I've just annotated my tests to print $CONTENT_LENGTH, and it does seem to jive
with the ~10k number described in 130301.  Its highly likely that this is a dupe
of that bug, but time will tell...

Comment 3

16 years ago
i don't see the problem with either mozilla 0.9.9 or linux trunk build #2002040302
(Assignee)

Comment 4

16 years ago
please test this again with a brand new build. the bug 130301 is fixed so this
should work too. mark as a duplicate please. (get new builded binaries from
ftp.mozilla.org/pub/mozilla/...)

Comment 5

16 years ago
this works on linux build 2002-05-13

*** This bug has been marked as a duplicate of 130301 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 6

16 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.