Pop acnts:Sent Copy of MDN Request messages should have MSG_FLAG_MDN_REPORT_NEEDED turned off

VERIFIED FIXED

Status

MailNews Core
Backend
VERIFIED FIXED
16 years ago
4 years ago

People

(Reporter: Jeff Tsai, Assigned: Jeff Tsai)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

Trunk
x86
Windows 2000
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2])

Attachments

(1 attachment, 1 obsolete attachment)

1.45 KB, patch
Bienvenu
: superreview+
Details | Diff | Splinter Review
(Assignee)

Description

16 years ago
Sent folder copy of MDN Request messages should have the 
MSG_FLAG_MDN_REPORT_NEEDED flag turned off otherwise if the user mark it unread 
and then read it again will trigger the MDN report generation process.

Updated

16 years ago
QA Contact: gayatri → gchan
(Assignee)

Comment 1

16 years ago
Accepting ...
Status: NEW → ASSIGNED
(Assignee)

Comment 2

16 years ago
Adding JF. David & JF, do we create msgDBHeader when copying message to the Sent 
Folder at the sent time? I am trying to figure out where to set the flags.
sorry, no idea!

Comment 4

16 years ago
For IMAP, we don't, and can't (because we don't know what UID is, among other
things). We'll just need to ignore that flag in the sent folder, OR, not put
that header in the fcc msg.
(Assignee)

Comment 5

16 years ago
Guess what, 4.x has the same problem. Oops, I missed to test that on 4.x.....
Imap doesn't have this problem only Pop3. I tried to turned off the mdn needed
flag and turned on the mdn sent flag. Althoughm the flags get written to the
X-Mozilla-Status2: header the problem still exists. Not putting the request for
return receipt header to the fcc message may be the way to go after.
(Assignee)

Comment 6

16 years ago
Created attachment 78973 [details] [diff] [review]
Patch ready for review

This seems the right thing to do to passively prevent user mark the message
unread and read to trigger to MDN generation process.
Comment on attachment 78973 [details] [diff] [review]
Patch ready for review

R=ducarroz
Attachment #78973 - Flags: review+

Comment 8

16 years ago
is all that neccessary? I'd rather not change the db code, and just have this
handled in the send code by itself.

Comment 9

16 years ago
OK, I'd prefer that you clear this hdr flag in the send listener code, probably
in SetMessageKey().
(Assignee)

Comment 10

16 years ago
Created attachment 79217 [details] [diff] [review]
Patch for final review

Better and correct fix to ensure flags in sync with X-MOZILLA-STATUS2 value.
Attachment #78973 - Attachment is obsolete: true

Comment 11

16 years ago
Comment on attachment 79217 [details] [diff] [review]
Patch for final review

sr=bienvenu, that's even much better.
Attachment #79217 - Flags: superreview+

Comment 12

16 years ago
Does this mean that the user will send out another request for a return receipt
to the recipient or that the user will potentially reply to their own receipt or
that the user will reply again to the sender?
Keywords: nsbeta1+
Whiteboard: [adt2]

Comment 13

16 years ago
If the user opens their sent folder, and reads the sent message, they will
potentially be prompted to send out another return receipt (or send it
automatically if that's their setting). It's also possible that the filtered
messages MDN bug might come into play if it isn't fixed, so that just opening
the sent folder might cause a prompt to send the return receipt.

Comment 14

16 years ago
Please check this into the trunk and after it's been tested, update the bug.

Nominating for adt1.0.0 because we shouldn't unexpectedly send return receipts.
Keywords: adt1.0.0
(Assignee)

Comment 15

16 years ago
Fix checked in to the trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Updated

16 years ago
Blocks: 134040

Comment 16

16 years ago
using commercial builds:
2002-04-16-06-trunk NT 4.0
2002-04-16-07-trunk linux 2.2
2002-04-16-03-trunk  mac 10.1.3

Ok assuming assuming I understand this bug: this bug fixes
any weird cases where the mesg that has RR on it,
if marked new again, and read will reprompt the user or
auto send a RR.

This is what I tested:
 -Sent a mesg to myself with RR on, read it, sent RR back,
  marked old mesg as new (via green dot) and reread it again. No RR prompt
  occurred. Both IMAP/POP acnts.
 -Tested POP accounts where I went into sent folder (under Pop acnts
  since can't test sent folder under local folders due to bug 135987)
  marked mesg as new and read it. NO RR prompt or auto send of RR.

I'm confused about David's comment 4 for Imap. I wasn't sure
the fix was intended just for Pop or Imap or both accounts.

I think it was intended for both accounts. If so, then I found
a problem with Imap accounts.

Steps to reproduce:
1.Create a imap mail account.
2.Turn Return Receipts on both (request for RR and ask you
  if you are prompted for RR)
3.Make sure your Sent folder is located under your Imap account
4.Compose a mesg to yourself and send it w/RR on.
5.Get the mesg
6.Click on the mesg and RR prompt appears
7.Send the RR back
8.Get the mesg
9.RR is in your inbox (assuming that is where you wanted RR to be)
10.Click on your sent folder
11.Scroll down to copy of the orig mesg in step 4
12.Mark it as new via clicking on green dot.
13.Mesg should be bold
14.Click on the mesg

result: Return Receipt prompt appears
Expected: Return Receipt to not appear

If try to mark it as new again and all subsequent tries afterwards,
the RR prompt never appears. It only appears the very FIRST TIME
you try this.

reopening. If I'm under the wrong assumption please let me know.


Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 17

16 years ago
The fix is really meant for pop3 accounts only. Imap accounts used to work okay.
Could we change the title of this bug for Pop3 and create a new bug to address
the Imap problem. The bug is related to the way we download message headers from
imap server. It also involves with custom headers filter bug. 

Comment 18

16 years ago
Ok assuming no one else objects.

I resolve this bug and open a new bug for imap only.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Comment 19

16 years ago
Ok imap bug is bug 138054.

Added pop acnts to summary line

Verified on trunk.
Summary: Sent Copy of MDN Request messages should have MSG_FLAG_MDN_REPORT_NEEDED turned off → Pop acnts:Sent Copy of MDN Request messages should have MSG_FLAG_MDN_REPORT_NEEDED turned off

Comment 20

16 years ago
adt1.0.0+ (on ADTs behalf) approval for checkin to 1.0 branch. Pls check this
into the 1.0 branch and trunk today. After, this has landed on the branch, pls
add the fixed1.0.0 keyword.
Keywords: adt1.0.0 → adt1.0.0+

Comment 21

16 years ago
imap version of this bug is bug 138054

Comment 22

16 years ago
marking verified (since verified on trunk only)


needs to land on branch and keywords addded 
Status: RESOLVED → VERIFIED
(Assignee)

Comment 23

16 years ago
David, could you check this in for me to the mozilla 1.0 branch? I am not sure 
when mozilla 1.0 branch will be open. Thanks,
(Assignee)

Comment 24

16 years ago
Fix checked in to the branch.
Keywords: fixed1.0.0

Comment 25

16 years ago
Using commercial branch
2002-04-23-08-1.0.0 nt 4.0, linux 2.2
2002-04-23-05-1.0.0/ mac 9.2.2
2002-04-23-05-1.0.0/ mac 10.1.3

verified that any copy of mesg that's in the sent folder
(under the acccount only) of a pop account, if you mark it
as new and click on it, you will not be prompted to send Return
Receipt.

Verified on pop accounts only.

removing keyword fixed1.0.0 and replacing it with verified1.0.0

Verified on branch.
Keywords: fixed1.0.0 → verified1.0.0
Product: MailNews → Core
Product: Core → MailNews Core

Updated

4 years ago
Depends on: 402330
You need to log in before you can comment on or make changes to this bug.