time stamp for "minimize memory usage" in about:memory

VERIFIED FIXED in Firefox 54

Status

()

Toolkit
about:memory
--
enhancement
VERIFIED FIXED
2 years ago
a year ago

People

(Reporter: Rolf Leggewie, Assigned: njn)

Tracking

Trunk
mozilla54
Points:
---

Firefox Tracking Flags

(firefox54 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Currently, you get a message of "Memory minimization completed" when clicking the "minimize memory usage" button in about:memory.  This takes a few seconds.  When you click it again it is unclear if the minimization has already finished or not.  It would be nice to add a time stamp to the completion message to make it clear if the process has finished or not.
Component: Untriaged → about:memory
Product: Firefox → Toolkit
Version: unspecified → Trunk
(Assignee)

Comment 1

2 years ago
Created attachment 8832700 [details] [diff] [review]
Add a timestamp to some about:memory messages

Specifically, after: "GC", "CC, "Minimize memory usage", "Measure and save",
and "Save DMD output".

Example: "Memory minimization completed (2017-02-02T00:32:41.607Z)".
Attachment #8832700 - Flags: review?(erahm)
(Assignee)

Updated

2 years ago
Assignee: nobody → n.nethercote
Status: NEW → ASSIGNED
Comment on attachment 8832700 [details] [diff] [review]
Add a timestamp to some about:memory messages

Review of attachment 8832700 [details] [diff] [review]:
-----------------------------------------------------------------

r=me We don't need to update tests do we?

::: toolkit/components/aboutmemory/content/aboutMemory.js
@@ +139,5 @@
>  var SHOW_FOOTER = 1;
>  
> +// Values for the |aShowTimestamp| argument to updateTitleMainAndFooter.
> +var NO_TIMESTAMP = 0;
> +var SHOW_TIMESTAMP = 1;

These could be |const|.
Attachment #8832700 - Flags: review?(erahm) → review+

Comment 4

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/cc9a42d772cf
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox54: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID 	20170203030204

The issue is no longer reproducible on the latest Nightly.
(Reporter)

Comment 6

2 years ago
Awesome, thank you!
(In reply to Ciprian Muresan [:cmuresan] from comment #5)
> User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0)
> Gecko/20100101 Firefox/54.0
> Build ID 	20170203030204
> 
> The issue is no longer reproducible on the latest Nightly.

Updating status flags.
Status: RESOLVED → VERIFIED
status-firefox54: fixed → verified
You need to log in before you can comment on or make changes to this bug.