Sometimes, Google video/news/shopping search does not work.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: alice0775, Unassigned)

Tracking

({jp-critical})

51 Branch
x86
Windows 10
jp-critical
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [parity-Chrome][parity-Edge])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Build Identifier:
https://hg.mozilla.org/releases/mozilla-release/rev/327e081221b064b05a302d7877c6e4be2949a617
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0 ID:20170125094131


I am not sure that this is only in Japanese region or not.

I am using en-US version of Firefox. So, google redirected to google.co.jp from google.com when search is executed.

Reproducible: sometimes

Steps To Reproduce:
0. Disabled e10s due to a11y
1. Clear History (Ctrl+Shift+Del) everything
2. Search something(e.g. "mozilla") from SearchBar(defaut engine is Google)
3. Click on "もっと見る"(More) and "動画"(Videos)

Actual Results:
The search results is not shown.
The actual URL is https://www.google.co.jp/search?q=mozilla&ie=utf-8&oe=utf-8&client=firefox-b&gfe_rd=cr&ei=3VKLWIe3M6XEXs7KqpgJ#q=mozilla&tbm=vid

When the problem occure, reload(F5) does not help.

And an error is shown in Browser Console as follows:
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://www.google.com/_/og/promos/z. (Reason: CORS header ‘Access-Control-Allow-Origin’ missing). 


Expected Results:
The search results should be shown.
(Reporter)

Comment 1

2 years ago
Created attachment 8831122 [details]
screenshot
(Reporter)

Comment 2

2 years ago
Created attachment 8831124 [details]
about:support
(Reporter)

Updated

2 years ago
Component: Security → Untriaged
Summary: Sometimes, Google video search does not work. It seems due to Cross-Origin Request Blocked → Sometimes, Google video search does not work.
(Reporter)

Comment 3

2 years ago
news and shopping are also affected.
status-firefox52: --- → affected
Summary: Sometimes, Google video search does not work. → Sometimes, Google video/news/shopping search does not work.
(Reporter)

Updated

2 years ago
status-firefox53: --- → affected
(Reporter)

Comment 4

2 years ago
Nightly54.0a1 is also affected.
status-firefox54: --- → affected
(Reporter)

Comment 5

2 years ago
screen cast https://youtu.be/UoWpLPNb7PA, see 0:35-
(Reporter)

Comment 6

2 years ago
This is not a recent regression because I can reproduce on 37.0a1.
(Reporter)

Updated

2 years ago
Whiteboard: [parity-Chrome][parity-Edge]
(Reporter)

Comment 7

2 years ago
it seems to fixed by google, i cannot reproduce it any more.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox51: affected → ---
status-firefox52: affected → ---
status-firefox53: affected → ---
status-firefox54: affected → ---
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.