Firefox could not install search engines

RESOLVED DUPLICATE of bug 1328104

Status

()

Firefox
Search
RESOLVED DUPLICATE of bug 1328104
a year ago
a year ago

People

(Reporter: ccomorasu, Unassigned)

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(firefox51 unaffected, firefox52 unaffected, firefox53 affected, firefox54 affected)

Details

[Affected versions]:
  Fx 53.0a2
  Fx 54.0a1

[Affected platforms]:
 Ubuntu 14.04 LTS x64
 Ubuntu 16.04 LTS x64
 Ubuntu 16.04 LTS x86

[Steps to reproduce]:
 1. Launch Firefox.
 2. Go to "www.baidu.com" .
 3. Click on the the "+magnifying glass" icon.
 4. Select the "Add Baidu" search engine.

[Expected result]:
 The search engine is installed without any issues.

[Actual result]:
 The drop down engine closes and the search engine does not install.

[Regression range]:
 Last good revision: 55a41c5e8e88010ea8a539c009f27b7b14988700
 First bad revision: 3e92691272d3139d0f428bf7499bc65f7318f540
 Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=55a41c5e8e88010ea8a539c009f27b7b14988700&tochange=3e92691272d3139d0f428bf7499bc65f7318f540

 Looks like the following bug has the changes which introduced the regression:
https://bugzilla.mozilla.org/show_bug.cgi?id=1113747

[Additional notes]:
 a. This issue is only reproducible on Ubuntu.
 b. Other search engines are also affected (i.e. ask Ubuntu, Firefox add-ons, maybe others).
status-firefox51: --- → unaffected
status-firefox52: --- → unaffected
status-firefox53: --- → affected
Has Regression Range: --- → yes

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1328104
You need to log in before you can comment on or make changes to this bug.