unable to display 'netscape messenger express' webmail interface

VERIFIED DUPLICATE of bug 132952

Status

()

Core
DOM: Core & HTML
--
major
VERIFIED DUPLICATE of bug 132952
16 years ago
16 years ago

People

(Reporter: Rudmer van Dijk, Assigned: jst)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.9+) Gecko/20020325
BuildID:    2002032503

mozilla is unable to display the webmail interface (netscape messenger express)
since build 20020319xx. In the javascript console the following error is present
(2x):
Error: redeclaration of const hide
Source File: chrome://wallet/content/walletOverlay.js
Line: 1
Two (empty) frames are present, with source code. the size of these frames does
not have the size when the webmail interface is correctly displayed.

And after reloading one of the two frames:
Error: popup has no properties
Source File: chrome://messenger/content/mailNavigatorOverlay.xul
Line: 100

after disabeling the line which declares const hide I found out that the
declarations of const enable and const disable are also double.

Reproducible: Always
Steps to Reproduce:
1. Log in



Actual Results:  No webmail interface

Expected Results:  webmail interface

Comment 1

16 years ago
Looks like a duplicate of the document.write() bugs we've had 
ever since the patch for bug 123899 was checked in around the time
you mention.

This caused bug 132673 "last thing in a script created with document.write
does not show", and many bugs have been duped against it; for example,
bug 132952, "Problem with viewing your mail acnt once you are logged in"


> I noticed with Current commercial trunk builds (3/20,21,22)
> if I try to login to a Netscape mesg server through the browser,
> I can get in fine but the pages aren't displayed properly.
> Instead of seeing mail folders, mesgs, etc.. All I see is a 
> blank page with gray top and white bottom (colors Messenger uses.

> I have tried various test mail servers we have here in mail qa
> and after I login, the browser is blank.


That sound just like this bug. I'm going to reassign this to 
DOM Level 0 and dupe this. The warnings you're seeing in the
JS Console are red herrings: they occur at many different sites.

Assignee: rogerl → jst
Component: JavaScript Engine → DOM Level 0
QA Contact: pschwartau → desale

Comment 2

16 years ago
Duping this against bug 132952.

Rudmer: could you confirm this? You'll have to get a new build
made after the patch for bug 123899 was backed out, which was 
done today, 2002-03-26, at 04:34 Pacific Standard Time.

If the bug has gone away with the new build, you can mark this
bug "Verified". If not, you can reopen it - thanks.

*** This bug has been marked as a duplicate of 132952 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

16 years ago
OK, verified.

For build 2002032603, from dir 2002032605 (mozilla.exe from 5:27h) it still did
not work.
For build 2002032603, from dir 2002032610 (mozilla.exe from 9:39h) it works again!
Status: RESOLVED → VERIFIED

Comment 4

16 years ago
Rudmer: thanks for verifying this, and thank you for this report.
You need to log in before you can comment on or make changes to this bug.