Closed Bug 1334552 Opened 4 years ago Closed 4 years ago

Mozilla Firefox 51.0.1 (32-bit) on XP SP3 is buggy causing Explorer.exe error!

Categories

(External Software Affecting Firefox :: Other, defect)

x86
Windows XP
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: antene, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.118 Safari/537.36
Build ID: 20170118123726

Steps to reproduce:

Following updating Mozilla Firefox to v.51.0.1 (32-bit) on a very stable XP SP3 system I found a repetitive pattern of errors at Explorer.exe.
 At the closing of it's (Explorer) window generated same error: event 1000 / Faulting application explorer.exe, version 6.0.2900.5669, faulting module unknown, version 0.0.0.0, fault address 0x04e14b93.


Actual results:

I googled and tried everything...nothing worked. Finaly I reinstalled today the OS in repair mode w.older FF37 at first, and everything was fine, then I updated to FF51.0(32-bit), still fine and finally using FF's Help/About Firefox I updated to Mozilla Firefox latest 51.0.1 (32-bit) and surprise THE Explorer.exe BUG REAPPEARED! Replacing the buggy version with the older Mozilla Firefox 51.0. (32-bit) solved the problem.


Expected results:

By chance I solved the problem. In conclusion the latest Mozilla Firefox 51.0.1 (32-bit) IS BUGGY!
Good luck at repair and thanks for your work!
Sandy
Severity: normal → critical
OS: Unspecified → Windows XP
Hardware: Unspecified → x86
[Tracking Requested - why for this release]:
See Also: → 1334503
antene, do you have an antivirus? If yes, which one (version)?
Flags: needinfo?(antene)
This problem is caused by updating from Firefox 50.1.0 to 51.0.1 with no changes to Norton on XP systems.

Many people are having this SYSTEM CRASH caused by updating Firefox, and they have no idea what is causing it, and their Firefox browser is dead and unusable due to this loop situation in Firefox 51.0.1 when running on XP.  It also crashes stable XP systems.  

Firefox is the only current browser we have on XP!  That is the one reason that hundreds of thousands still use Firefox! (If not millions!)

Firefox needs to look at this.  Norton has made no changes.  Dropping back (if one knows how) to Firefox 50.1.0 stops the problem.  FIREFOX, HELP!

Tens of thousands of conathst.exe processes are being created - looks like Norton defending itself against Firefox access.  Problem DOES NOT occur on Windows 7 usinf exactly same Norton Internet Security release and options.  Something FFOX 51.0.1 is doing on XP that FFOX 50.1.0 does not do is causing problem.  Norton says error is 

Category: Norton Product Tamper Protection
Date & Time,Risk,Activity,Status,Recommended Action,Date,Actor,Actor PID,Target,Target PID,Action,Reaction
1/27/2017 8:09:09 PM,Medium,Unauthorized access blocked (Assign Process To Job Object),Blocked,No Action Required,1/27/2017 8:09:09 PM,C:\PROGRAM FILES\MOZILLA FIREFOX\FIREFOX.EXE,2392,C:\Program Files\Norton Internet Security\Engine\22.8.1.14\conathst.exe,14820,Assign Process To Job Object,Unauthorized access blocked

Firefox 51.0.1 then repeats the function that got the error repeatedly causing loop (high CPU) creating conathst.exe tasks until Firefox or XP crashes.
(In reply to Loic from comment #2)
> antene, do you have an antivirus? If yes, which one (version)?

I use Comodo 8.4.0.5165 with up to day AV database at Stateful and Malwarebites Anti Malware also up to day... and nothing was found. I tested Online explrer.exe after the error and it was OK.
(In reply to adm101 from comment #3)
> This problem is caused by updating from Firefox 50.1.0 to 51.0.1 with no
> changes to Norton on XP systems.
> 
> Many people are having this SYSTEM CRASH caused by updating Firefox, and
> they have no idea what is causing it, and their Firefox browser is dead and
> unusable due to this loop situation in Firefox 51.0.1 when running on XP. 
> It also crashes stable XP systems.  
> 
> Firefox is the only current browser we have on XP!  That is the one reason
> that hundreds of thousands still use Firefox! (If not millions!)
> 
> Firefox needs to look at this.  Norton has made no changes.  Dropping back
> (if one knows how) to Firefox 50.1.0 stops the problem.  FIREFOX, HELP!
> 
> Tens of thousands of conathst.exe processes are being created - looks like
> Norton defending itself against Firefox access.  Problem DOES NOT occur on
> Windows 7 usinf exactly same Norton Internet Security release and options. 
> Something FFOX 51.0.1 is doing on XP that FFOX 50.1.0 does not do is causing
> problem.  Norton says error is 
> 
> Category: Norton Product Tamper Protection
> Date & Time,Risk,Activity,Status,Recommended Action,Date,Actor,Actor
> PID,Target,Target PID,Action,Reaction
> 1/27/2017 8:09:09 PM,Medium,Unauthorized access blocked (Assign Process To
> Job Object),Blocked,No Action Required,1/27/2017 8:09:09 PM,C:\PROGRAM
> FILES\MOZILLA FIREFOX\FIREFOX.EXE,2392,C:\Program Files\Norton Internet
> Security\Engine\22.8.1.14\conathst.exe,14820,Assign Process To Job
> Object,Unauthorized access blocked
> 
> Firefox 51.0.1 then repeats the function that got the error repeatedly
> causing loop (high CPU) creating conathst.exe tasks until Firefox or XP
> crashes.

Thank you  adm101 for your detailed and well intended answer but I'm not using Norton(I'm not a fan of Norton products). As i replied before: I use Comodo 8.4.0.5165 with up to day AV database and engine!,setted at Stateful and Malwarebites Anti Malware also up to day... and nothing was found. I tested Online explrer.exe after the error and it was OK with correct checksum file. In my case Firefox 51.0.1 was still 100% functional, explorer worked fine until I closed it's window. In that moment appeared the described error warning.
(In reply to YF (Yang) from comment #1)
> [Tracking Requested - why for this release]:

I ment it by mistake. I'm waiting for the next update. I'm interested if anybody else has similar problems.
(In reply to antene@k.ro from comment #5)
> (In reply to adm101 from comment #3)
> > This problem is caused by updating from Firefox 50.1.0 to 51.0.1 with no
> > changes to Norton on XP systems.
> > 
> > Many people are having this SYSTEM CRASH caused by updating Firefox, and
> > they have no idea what is causing it, and their Firefox browser is dead and
> > unusable due to this loop situation in Firefox 51.0.1 when running on XP. 
> > It also crashes stable XP systems.  
> > 
> > Firefox is the only current browser we have on XP!  That is the one reason
> > that hundreds of thousands still use Firefox! (If not millions!)
> > 
> > Firefox needs to look at this.  Norton has made no changes.  Dropping back
> > (if one knows how) to Firefox 50.1.0 stops the problem.  FIREFOX, HELP!
> > 
> > Tens of thousands of conathst.exe processes are being created - looks like
> > Norton defending itself against Firefox access.  Problem DOES NOT occur on
> > Windows 7 usinf exactly same Norton Internet Security release and options. 
> > Something FFOX 51.0.1 is doing on XP that FFOX 50.1.0 does not do is causing
> > problem.  Norton says error is 
> > 
> > Category: Norton Product Tamper Protection
> > Date & Time,Risk,Activity,Status,Recommended Action,Date,Actor,Actor
> > PID,Target,Target PID,Action,Reaction
> > 1/27/2017 8:09:09 PM,Medium,Unauthorized access blocked (Assign Process To
> > Job Object),Blocked,No Action Required,1/27/2017 8:09:09 PM,C:\PROGRAM
> > FILES\MOZILLA FIREFOX\FIREFOX.EXE,2392,C:\Program Files\Norton Internet
> > Security\Engine\22.8.1.14\conathst.exe,14820,Assign Process To Job
> > Object,Unauthorized access blocked
> > 
> > Firefox 51.0.1 then repeats the function that got the error repeatedly
> > causing loop (high CPU) creating conathst.exe tasks until Firefox or XP
> > crashes.
> 
> Thank you  adm101 for your detailed and well intended answer but I'm not
> using Norton(I'm not a fan of Norton products). As i replied before: I use
> Comodo 8.4.0.5165 with up to day AV database and engine!,setted at Stateful
> and Malwarebites Anti Malware also up to day... and nothing was found. I
> tested Online explrer.exe after the error and it was OK with correct
> checksum file. In my case Firefox 51.0.1 was still 100% functional, explorer
> worked fine until I closed it's window. In that moment appeared the
> described error warning.

Thanks for the reply!  GoOd to know that the problems are not related to specific security package, but are related to Firefox 51.0.1 runnIng on XP causing big problems.  FIREFOX/Mozilla - HELP HELP!
Do you have any strong steps to reproduce the issue on Win XP?

It could help someone from QA to test the issue.
(In reply to Loic from comment #8)
> Do you have any strong steps to reproduce the issue on Win XP?
> 
> It could help someone from QA to test the issue.

Yeah, In my case, update to Firefox 51.0.1 on an XP system with latest Norton Internet Security on it.
Start Firefox, and the loop creating conathst.exe processes begins as Firefox comes up, and they continue to be created by the 10's of thousands at max CPU, until Firefox is brought down, crashes, or XP dies.  Looks like an access by Firefox is repeatedly rejected by Norton, and Firefox retries it.  Firefox is functioning during all of this, by the way.
About the Norton issue, I read a similar report on the French community board. The user got many alerts killing his computer.
Flags: needinfo?(antene)
Sandy, after you get a crash, please go to about:crashes page, copy the Report ID and paste it here in a comment. It would be interesting to see what crashes.
Flags: needinfo?(antene)
(In reply to Vlad Bacia-Mociran [:VladB] from comment #11)
> Sandy, after you get a crash, please go to about:crashes page, copy the
> Report ID and paste it here in a comment. It would be interesting to see
> what crashes.

Please understand this: Following updating Mozilla Firefox to v.51.0.1 (32-bit) on a very stable XP SP3 system I found a repetitive pattern of errors at Explorer.exe. Explorer crashes NOT FIREFOX, but in the future, if it  hapens...
Here is a thread regarding the AV and Firefox crashes: https://support.mozilla.org/en-US/questions/1086722

Given the fact that the issue is specific to your setup, could you please try to find a regression range using Mozregression tool?
Information on the tool is available at http://mozilla.github.io/mozregression/. Please don't hesitate to contact us if you encounter any problems.
Flags: needinfo?(antene)
Flags: needinfo?(antene)
In my case the problem was solved by replacing ACDSee Photo Manager 5 and Picaview 2 with actual release of XnView-win.NOW I'm using Mozilla Firefox to v.51.0.1 (32-bit) and it seems to work right for now. Thank you all for your help.
Based on Comment 14 from the reporter, changing status to RESOLVED-WORKSFORME.

If anyone can still reproduce it on latest versions, feel free to reopen the issue and provide more information.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Flags: needinfo?(antene)
Resolution: --- → WORKSFORME
Component: Untriaged → Other
Product: Firefox → External Software Affecting Firefox
Version: 51 Branch → unspecified
You need to log in before you can comment on or make changes to this bug.