At end of a transform transition, the transitioned element snaps back to its "start" position for a fraction of a second

RESOLVED FIXED in Firefox 54

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: dholbert, Assigned: dvander)

Tracking

({regression})

Trunk
mozilla54
regression
Points:
---

Firefox Tracking Flags

(firefox52 unaffected, firefox53 unaffected, firefox54 fixed)

Details

Attachments

(4 attachments)

(Reporter)

Description

2 years ago
Created attachment 8831359 [details]
testcase 1

STR:
 1. Load attached testcase.
 2. Click the button. (This simply adjusts "transform", on an element that has "transition:transform")


ACTUAL RESULTS
After the transform completes, the div **snaps back to its original location** for a fraction of a second, before finally snapping again to its correct final resting spot.

EXPECTED RESULTS:
The div should not snap back to its original location at the end of the transition.


Firefox Nightly 54 gives ACTUAL RESULTS.

Chrome 57 gives EXPECTED RESULTS.
Firefox Nightly 54 with e10s *forcibly disabled* gives EXPECTED RESULTS.  (So, the bug only happens when e10s is enabled. Maybe that means this is an OMTA bug?)


Side note: I locally tried adding "will-change: transform", on a whim that this was a layer-flattening bug, but that doesn't change the results.
(Reporter)

Comment 1

2 years ago
Created attachment 8831361 [details]
screencast of bug in Firefox vs. no-bug in Chrome
(Reporter)

Comment 2

2 years ago
I've tested in latest Nightly on Windows and Linux, and I can reproduce on both.
(Reporter)

Comment 3

2 years ago
Actually I think this might be a recent regression. Tracking down a range now.
Keywords: regression
(Reporter)

Comment 4

2 years ago
Regression from bug 1332567.  Pushlog:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=f0248c53cef751d0eed4c9d1979d69f32dc5c617&tochange=44f9535628fd46d78fe020a8175bedc5f8b98680

mattwoodrow or dvander, could you take a look at this?  (My initial impression is that this is glitchy enough that we might even want to back out or disable bug 1332567's changes, if we can't get a fix in a couple of days...)
Blocks: 1332567
Flags: needinfo?(dvander)
(Reporter)

Comment 5

2 years ago
Created attachment 8831369 [details]
testcase 2 (automated, no clicking needed)
(Reporter)

Updated

2 years ago
Flags: needinfo?(matt.woodrow)
Taking to investigate.
Assignee: nobody → dvander
Status: NEW → ASSIGNED
Flags: needinfo?(matt.woodrow)
Flags: needinfo?(dvander)
Attachment #8831924 - Flags: review?(matt.woodrow) → review+

Comment 8

2 years ago
Pushed by danderson@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a9563d52ca61
Fix missing mutation when changing SimpleLayerAttributes. (bug 1334715, r=mattwoodrow)

Comment 9

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/a9563d52ca61
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox54: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla54

Updated

2 years ago
Duplicate of this bug: 1334801
status-firefox52: --- → unaffected
status-firefox53: --- → unaffected
You need to log in before you can comment on or make changes to this bug.