slow switching between channels

RESOLVED FIXED

Status

RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: andrixnet, Assigned: rginda)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
build 2002031104


Description 
Don't know why in chatzilla tabs are called views...

Anyway: there is no intuitive way to know how to close a "view".
By user interface design in many other programs, including Mozilla's tabbed
browsing feature, a right-click on a tab leaf will bring a menu from which a
"close tab" option can be used to close it. 
However, chatzilla does not feature such menu. 
A similar menu exists in the view area for right-click and this one offers the
close option. But it is not intuitive and also when changing between views
(users, channels, etc) an additional step is required to close a view.

Also, naming is not uniform.
While "leave channel" is an appropriate name for a channel view, it is not
straightforward for people migrating from other IRC clients that are more
consistent in the user interface.

Another issue related to view changing : 

- when 2 or more channels are active, switching between them takes a HUGE time.
(athlon 650/256ram, only mozilla with this window and chatzilla with 2 channels
open on undernet with moderate traffic...)

Reproductibility: every time

Steps to recreate:
1. right-click on a tab in chatzilla. nothing happens. Menu appears for
right-click only in window area
1. open chatzilla. connect. open some channels
2. try switching between channels. It takes a very long time (seconds) to
display another channel and during this interval, chatzilla does not respond to
any command.
3.

Expected results :
A consistent nameing of commands related to control of the tabbed windows in
chatzilla. (why views here and tabs in mozilla anyway?)

right-click functionality on tabs in chatzilla

improvement in speed when switching between channes. Way to slow. (maybe still
unoptimized).

Missing functionality : 
- ignore user does not exist (spammers on IRC are very annoying and very persistent)
- apparently DCC still not implemented

Severity : Minor + Enhancement

Comment 1

17 years ago
Thanks for the input, but keep in mind that bugs are meant to deal with one
issue at a time.  After looking your bug over, I had a hard time figuring out
what your real issue was.

It is often useful to use the Bugzilla Helper until you get the feel for Bugzilla:

http://www.mozilla.org/quality/help/bugzilla-helper.html

You will also want to check for duplicates before you file a bug.  It is really
easy to check ChatZilla since there are only about 100 open bugs total.

> improvement in speed when switching between channes. Way to slow.

This is a known issue, but I don't see a bug for it.  If you want to file a bug
on that issue, carefully check for duplicates just to be sure, then file a new bug.

> - ignore user does not exist (spammers on IRC are very annoying and very
persistent)

bug 111475

> - apparently DCC still not implemented

bug 73257

Comment 2

17 years ago
the UI issues in this report are a bit vague.  of the clear issues mentioned,
two are dupes of other bugs, but I don't see another bug for the slowness. so...

updating summary to make this bug "slow switching between channels".  the
slowness is noticable (i'm on a p4 1.7Ghz here, win2k, build 2002061008, and it
takes a while). confirming.

reporter (Andrei): if you still want to report the UI issues, you'll need to
file separate bugs giving a clear description of what you think should be changed.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: non-intuitive UI and slow switching between views → slow switching between channels

Updated

17 years ago
Status: NEW → ASSIGNED
OS: Windows 95 → All
Hardware: PC → All

Comment 3

17 years ago
Created attachment 90355 [details] [diff] [review]
make chatzilla use a <deck>

This patch converts the content pane into a deck with a frame for each channel.
 This is much faster for switching tabs and I also fixed some other bugs in the
process which I will depend on this bug.

Updated

17 years ago
Keywords: patch, review

Updated

17 years ago
Blocks: 144193
(Assignee)

Comment 4

17 years ago
XPI posted to <http://www.hacksrus.com/~ginda/chatzilla/>.

If you disable "open at startup" for the client view, all your tabs end up off
by one :(

Comment 5

17 years ago
I think to cz0.8.9a has a bug.

Please test next case.

/server irc.mozilla.org
/join #aaa
/join #bbb

Leave #aaa by right clice menu.

I can't use #bbb

(Assignee)

Comment 6

17 years ago
deleting views isn't working properly with this patch :(

Comment 7

17 years ago
The fix is to change in handlers.js 2 lines that have "view.browser" to
"view.frame".  rginda has the fix
(Assignee)

Updated

17 years ago
Depends on: 160462
(Assignee)

Comment 8

17 years ago
checked in to trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.