Drag and drop images out of the browser fails after update to 51.0.1 today.

UNCONFIRMED
Unassigned
(NeedInfo from)

Status

()

Core
Widget: Win32
UNCONFIRMED
a year ago
a year ago

People

(Reporter: Fred, Unassigned, NeedInfo)

Tracking

51 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

Drag and drop images out of the browser fails after update to 51.0.1 today.
Opeing images as the sole element on the page, I used to be able to drag them to a folder our of firefox.  Now certain sites dont work, many others do.

This one does NOT drag and drop to the desktop anymore:
https://www.gstatic.com/tv/thumb/movieposters/9635831/p9635831_p_v8_ae.jpg

another:
https://t3.gstatic.com/images?q=tbn:ANd9GcTS1VqOgP7iJC44UcztFaTbvD0OzoRymEhXfMPlgq7FPY0OEvCj




Actual results:

nothing.  cant drag it out of firefox.  Many other sites still work.

I can right click and save-as.  This still works.


Expected results:

File dragged from the browser should drop into my file manager app.

Seems to me its mainly this site:  https://t3.gstatic.com/
But a few other sites are the same.

Comment 1

a year ago
WFM in Fx51.0 x86, Fx51.0.1 x86 and Fx52.0b1 x64 on Win10.

Comment 2

a year ago
Could you test with a frsh profile, please.
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

In addition, what's the name of your file manager?
Did you check the file manager is up-to-date after the update to FF51?
Flags: needinfo?(vicariat)
(Reporter)

Comment 3

a year ago
Seems to work now.  I had already rebooted, but on second reboot it works.
Win7, File manager is DOPUS11 and fully up to date.  
Sorry guys.
(Reporter)

Updated

a year ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
(Reporter)

Comment 4

a year ago
The issue is not resolved.  Certain images drag out of firefox into a 'Windows Explorer' window just fine.  I have now worked out that this problem ONLY affects files from googles image repository called gstatic.  Here are a bunch of examples, NONE of them drag out of the FF browser anymore since this update, but they all can be dragged out on another PC with version 51.0.1, and they all work with Chrome.

http://t1.gstatic.com/images?q=tbn:ANd9GcQ-oUkzbNurU_ZfuYXCkRWuLy2iwQDl5MkZI7TzGTTE9VI-__q4
http://t0.gstatic.com/images?q=tbn:ANd9GcTU9yNpefOYvBHDx-z41r3uomXPQ9nZuIoAllGa_sM93fc8KOeF
http://t3.gstatic.com/images?q=tbn:ANd9GcQ0Bvs7neWiv1VXOlsoEmSIHKyBhytlFd_mZQSo8B1L8wpU1JrO
http://www.gstatic.com/tv/thumb/movieposters/12661351/p12661351_p_v8_aa.jpg
http://www.gstatic.com/tv/thumb/movieposters/13242711/p13242711_p_v8_aa.jpg
http://t0.gstatic.com/images?q=tbn:ANd9GcRlLXfXWfquxU6kevsYL6OX29eCNJTIBqy85t9UWUatDBa67UF4
http://t0.gstatic.com/images?q=tbn:ANd9GcQsOonExbi2gK7Kb1xD9BFLawyygGs88MVZalYeTrXSc41RqtnF
http://www.gstatic.com/tv/thumb/dvdboxart/8005385/p8005385_d_v8_aa.jpg
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Updated

a year ago
Component: Untriaged → Widget: Win32
OS: Unspecified → Windows 7
Product: Firefox → Core
Hardware: Unspecified → x86_64

Comment 5

a year ago
Works for me with drop images of comment 4 from Firefox 51.0.1 (32 bits) to Directory Opus v11.19 Build 6005_64bit to save the image files, on Win10 x64.
You need to log in before you can comment on or make changes to this bug.