two instances of firefox.exe showing in my task manager after this current update. If I close one then I find my tabs have crashed.

RESOLVED INVALID

Status

()

RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: blackcat2, Unassigned)

Tracking

51 Branch
Unspecified
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

Updated firefox to the latest versoin 


Actual results:

two instances of firefox.exe are now showing in the task manager and if I close one then my open tabs crash. If I close the other then the whole browser shuts down. 


Expected results:

A single version of firefox.exe running after the current update.
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 7

Comment 1

2 years ago
This is not a bug, please read: 
https://developer.mozilla.org/en-US/Firefox/Multiprocess_Firefox
https://wiki.mozilla.org/Electrolysis/Multiple_content_processes
http://www.ghacks.net/2016/07/22/multi-process-firefox/
and so on. For example if you will run Google Chrome or Opera browser you will also notice multiple processes of chrome.exe / opera.exe - this is because Google Chrome and Opera have multi-process support already implemented. The multi-process in Firefox is in a Beta stage now, and with each next version of Firefox, the multi-process gets better and Firefox gets faster. In brief, multi-process makes a browser to run faster, smoother and more responsive, by using full capacity of the CPU by using all processor cores.

But to make sure, please check it and tell us: go to about:support --> Informations about the application --> Multi-process windows and you will notice that you almost certainly have it enabled, if you have multi-process enabled, then this bug is invalid and you should close it as "an invalid".

Updated

2 years ago
Flags: needinfo?(blackcat2)
(Reporter)

Comment 2

2 years ago
So how do I disable it then?

Comment 3

2 years ago
It's called multiprocess (e10s), please, read the release notes of Firefox 51.
https://www.mozilla.org/en-US/firefox/51.0/releasenotes/

If you have a support request, you can use the official support forum instead of Bugzilla:
https://support.mozilla.org/en-US/questions
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(blackcat2)
Resolution: --- → INVALID
(Reporter)

Comment 4

2 years ago
Okay but that doesn't tell me how to disable it? I guess I will just remove it and install the previous version then not update again.

Comment 5

2 years ago
As multi-process makes Firefox runs faster and better use your CPU, you shouldn't disable it, because if you do, this will make Firefox runs slower. why would you want to disable it then? You should disable it only if you have any issues with it, otherwise just leave it as is. Cores in PC's procesors are like cylinders in cars's engines. Nowadays most PCs, computer devices, smartphones, have CPU with multiple cores (multicore architecture), therefore applications which run on these devices should also support the multicore architecture, to reap the benfits from the multicore architecture and therefore to take advantage of all available power of a processor. Please read: https://en.wikipedia.org/wiki/Multi-core_processor . But if you really want to disable it for some reason, you should go to about:config --> and set browser.tabs.remote.autostart to false.

Comment 6

2 years ago
e10s is designed to be enabled by default in the future.
You can disable it by switching browser.tabs.remote.autostart to fasle in about:config.
(Reporter)

Comment 7

2 years ago
Thank you for the help on how to disable it. I know about processors and mine is a quad core. I built my computer myself several years ago. I also know about car engines. :) Thank you for the interesting analogy. I appreciate it.
Duplicate of this bug: 1334867
You need to log in before you can comment on or make changes to this bug.