WhatsApp Web emoji selector does not slide out smoothly

RESOLVED DUPLICATE of bug 1334715

Status

()

Core
Graphics: Layers
RESOLVED DUPLICATE of bug 1334715
a year ago
11 months ago

People

(Reporter: Fanolian, Unassigned)

Tracking

({regression, reproducible})

54 Branch
regression, reproducible
Points:
---

Firefox Tracking Flags

(firefox51 unaffected, firefox52 unaffected, firefox53 unaffected, firefox54 fixed)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Created attachment 8831439 [details]
Unsmooth WhatsApp Web emoji selector (2017-01-28 build)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170128030204

Steps to reproduce:

(Please refer to the attached video.)

0. Have a WhatsApp account.
1. Log in to https://web.whatsapp.com/.
2. In the chat window, click the emoji selector so it slides out.


Actual results:

The transition is not smooth.

Note:
Same as bug 1334715, the bug does not appear in non-e10s mode.
(Reporter)

Updated

a year ago
Blocks: 1332567
Has Regression Range: --- → yes
Has STR: --- → yes
Flags: needinfo?(dvander)
Keywords: regression, reproducible
This is actually unbearably slow for me on two builds I tried before that changeset: Firefox 52 beta, and the Nightly from 1/23. But, I tried selecting an emoji from the "Create Group" window instead of a chat window.

Does the "Create Group" window exhibit the same behavior for you? (Slow before, and slow after, that changeset?)
Flags: needinfo?(dvander) → needinfo?(Fanolian+bugzilla)
(Reporter)

Comment 3

a year ago
(In reply to David Anderson [:dvander] from comment #2)
> This is actually unbearably slow for me on two builds I tried before that
> changeset: Firefox 52 beta, and the Nightly from 1/23. But, I tried
> selecting an emoji from the "Create Group" window instead of a chat window.
> 
> Does the "Create Group" window exhibit the same behavior for you? (Slow
> before, and slow after, that changeset?)

No, the emoji selector in "Create Group" window is smooth for me, before or after the changeset.
Flags: needinfo?(Fanolian+bugzilla)
status-firefox51: --- → unaffected
status-firefox52: --- → unaffected
status-firefox53: --- → unaffected
status-firefox54: --- → affected
(Reporter)

Comment 4

a year ago
I can no longer reproduce this bug in 2017-02-01 build. It's probably fixed by bug 1334715.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1334715

Comment 5

11 months ago
Since 54 was fixed in bug 1334715, mark 54 fixed.
status-firefox54: affected → fixed
You need to log in before you can comment on or make changes to this bug.