VERY severe typing lag when alt + tabbing from Grim Dawn game

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: htc1325, Unassigned)

Tracking

51 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

- not sure if this is a bug with video drivers, a firefox problem or a Grim Dawn problem. 1st noticed it after installing drivers 16.12.2, which i installed in order to fix a mouse corruption issue (https://www.techpowerup.com/forums/threads/mouse-changing-pointer-by-itself.226353/)
- already left a bug report in AMD's site: https://community.amd.com/message/2732079 (2nd reply to that topic)
- got this in FF 50 but dunno if there were any updates to FF, which is why i'm not sure if this ISN'T a FF bug

- start Grim Dawn game and enter a char's game
- alt + tab
- whenever you try to type on firefox, the typing goes really slow, and i mean REALLY slow
- while the typing isn't finished, mouse's icon is incorrect and you can use it but you have to wait for the typing to end 1st before seeing whatever you clicked on
- as soon as game is exited, lag disappears
- refreshing firefox, as suggested before writing the bug report didn't work

- made a video of the problem to better explain it (https://www.youtube.com/watch?v=ANtfTkxUYjQ), but forgot to mention the mouse behaviour while expecting the typing to finish showing. My system's specs can be accessible from the AMD's report: better description of the issue is there as well
- next step is to leave a bug report on the Grim Dawn site


Actual results:

VERY severe lag when typing WHILE alt + tabbing from Grim Dawn game.

Tried to write this bug report while being alt + tabbed from the game but had to close it due to the typing lag: if i did this while alt + tabbing, it would take about 1 hour for the typing to show ... literally ...


Expected results:

Normal typing? As you type, the letter should appear normally: not the case, IF you're alt + tabbed from Grim Dawn game.
Dunno about this with other games because this is the only game i currently have installed.
Typing becomes normal once you exit the game.
(Reporter)

Updated

a year ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
(Reporter)

Updated

a year ago
Group: firefox-core-security

Comment 1

a year ago
Not a security bug.
Group: firefox-core-security
(Reporter)

Comment 2

a year ago
@Gijs - Sorry: messed up making the bug report.

As i said in OP, i 1st noticed this after installing drivers 16.12.2 for my graphics card but i didn't notice if there were any FF updates so i'm unsure wether this is FF related or not.
Hi htc1325,

Is the issue also reproducible when you try to write anywhere else (like Notepad)? Or is it just in Firefox?
If you also suspect your video drivers, have you tried rolling them back and seeing if the issue persists?
Flags: needinfo?(htc1325)
(Reporter)

Comment 4

a year ago
@Ciprian Muresan - I'm an idiot for not thinking of not using another program to write earlier ...

As a test, tried writing in a word document and the very same thing occurs, which rules out FF as the cause: it's either the drivers or Grim Dawn game that causes this issue.

As for your other question, i didn't because the other drivers caused mouse corruption (all versions i tried since buying my RX480), as described here: https://www.techpowerup.com/forums/threads/mouse-changing-pointer-by-itself.226353/ These drivers (16.12.2) fixed the mouse corruption.

Appologies for wasting time.
No problem :)

I'll close this off as Invalid then.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(htc1325)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.