Objects in cache randomly replaced by nonsense

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: walter, Assigned: gordon)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i386; en-US; rv:0.9.9) Gecko/20020313
BuildID:    2002031312

When browsing through a few sites using CSS, Mozilla can "forget" the linked CSS
stylesheet and from that moment on, displays everything in browser default
(which is very ugly).

An example is the site http://www.bluelight.nu/ with stylesheet
http://img.bluelight.nu/layout/s.css (mimetype checked: text/css).
After browsing a page or ten, twenty, the stylesheet disappears and the fonts
start looking ugly. I view the s.css file in Mozilla when the rendering goes
wrong. To my surprise Mozilla asserts its contents are (verbatim):

<html><body></body></html>

This is what Mozilla now thinks is in my s.css file, and this is not CSS, so
that's why the rendering goes wrong!

Now when I refresh the s.css file from the network by hitting Shift-Reload, the
REAL contents of the CSS file are suddenly being displayed! Subsequently, all
web pages using the s.css stylesheet are displayed properly.

I have the feeling that this is no a rendering problem but probably a
network/cache fluke. It appears that a CSS stylesheet file (maybe other elements
as well) in the cache gets its contents *replaced* by a file saying "<html>.."

I can test some more (e.g. without caches, using a proxy, etc) if needed. If
this bug was posted in the wrong category, sorry. :)

Reproducible: Sometimes
Steps to Reproduce:
1.Visit www.bluelight.nu
2.Browse around for 10-15 pages

Actual Results:  contents of the linked CSS file in cache are replaced by phoney
file "<html><body></body></html>"

Expected Results:  Either keep the *good* CSS file in the cache, or reload it
from the network. :)

Mozilla 2002031312, Linux binary
(Reporter)

Comment 1

17 years ago
A similar thing seems to happen to images. After a few minutes of browsing,
suddenly an image does not come up, this happened for instance with the image
http://img.bluelight.nu/ubb/icons/icon25.gif.

When navigating to the gif's url in the location field, Mozilla does not display
the contents gif file, but says its contents are (verbatim):

http://img.bluelight.nu/ubb/icons/icon25.gif

Yes a text string! Repeated to make more clear: Mozilla's cached copy of this
object is no longer a gif file, but a text file containing a *string* with the
location in it.

Shift-Reload on the gif file refreshes it from the network and subsequently all
pages containing a reference to this gif file are rendered properly.
Summary: CSS files in cache randomly replaced by nonsense → CSS files and images in cache randomly replaced by nonsense

Comment 2

17 years ago
Can't reproduce on 2002032521 Linux Nightly build.
(Reporter)

Comment 3

17 years ago
I've installed the 2002032606 and will see how it goes.
(Reporter)

Comment 4

17 years ago
Same problem on 2002032606.

It took me about 30 minutes of browsing though. Right now the images on
http://www.google.com/ suffer from the syndrome.
(Reporter)

Comment 5

17 years ago
This bug now also affected plain html files, i.e. I would browse to
http://www.lemis.com/, then return to the same page later to see it replaced with:

<html><body></body></html>

A reload does not solve it, a Shift-Reload does.

2002032606
Summary: CSS files and images in cache randomly replaced by nonsense → Objects in cache randomly replaced by nonsense

Comment 6

17 years ago
This can happen if you try to run more than one instance of mozilla at the same
time ... 

I've seen the behaviour you describe happen, but not in the past week.

Comment 7

17 years ago
Have seen it in 0.9.9 and 1.0 rc2 (2002051009), the rc1 seemed not to have the
problem.
can you reproduce this with 1.1beta?
(Reporter)

Comment 9

17 years ago
Problem does not seem to appear in 1.1beta! :)
:))
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.