If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Template does not load background picture when composing message

RESOLVED INVALID

Status

Thunderbird
Message Compose Window
RESOLVED INVALID
8 months ago
8 months ago

People

(Reporter: Carlos, Unassigned)

Tracking

52 Branch
x86_64
Windows 10

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [add-on: Stationery])

(Reporter)

Description

8 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

Tried to compose a message using a template with a picture background.
(I use the Stationeyr add-on)



Actual results:

The template's background picture did not load.
I then changed the configuration "mail.compose.attach_http_images" to "true" and still nothing happened.


Expected results:

Should have been able to compose a message using a template with a picture background.
(Reporter)

Updated

8 months ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64

Comment 1

8 months ago
Since version 52 TB will no longer show images in compositions that are referenced from files (<img src="file:// ...">. See bug 1322155.

We have notified add-on authors to adapt their add-ons. Please contact the add-on author, CC'ed here (Arivald).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → INVALID
See Also: → bug 1322155
Whiteboard: [add-on: Stationery]

Comment 2

8 months ago
Arivald, you need to copy this code to insert the content of files as data URI:
https://dxr.mozilla.org/comm-central/rev/fdc6a3e536479536fffdfd057d41e65aa191d871/mail/components/compose/content/MsgComposeCommands.js#5640
You need to log in before you can comment on or make changes to this bug.