crash when clicking right arrow key at the end of <textarea> control with absolute positioning.

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
--
critical
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Gadi Melamed, Assigned: rods (gone))

Tracking

({crash, testcase})

Trunk
x86
Windows 2000
crash, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; T312461)
BuildID:    20011019

When HTML form has a <textarea> with CSS absolute positioning, when the cursor 
is at the end of the textarea field and user click on the right arrow key, the 
browser crashes.

Reproducible: Always
Steps to Reproduce:
1. Visit a page with <textarea> that has absolute position CSS attr.

2. Enter the textarea field.

3. Click the right arrow key.

Actual Results:  The browser crashes.

Expected Results:  Nothing should happen.

Try:
<html>
   <head>
      <title>testcase</title>
   </head>
   <body>
      <textarea rows="5" cols="10" style="position: absolute; top: 10px; left: 
10px;"></textarea>
   </body>
</html>


Only happens when using "position: absolute" in style.
(Reporter)

Comment 1

16 years ago
Created attachment 76187 [details]
A testcase

Comment 2

16 years ago
Reporter, could you install the latest nightly build and try it again? Your
build is pretty old.
http://ftp.mozilla.org/pub/mozilla/nightly/latest/

WFM 2002032503/Win2K
Keywords: crash, testcase
(Reporter)

Comment 3

16 years ago
Can't reproduce on build 20020406.

Comment 4

16 years ago
thanks.
makring WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Updated

16 years ago
QA Contact: madhur → tpreston
You need to log in before you can comment on or make changes to this bug.