Compose window does not scroll down when reaching bottom of window 45.7.0

RESOLVED INVALID

Status

RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: JLJ, Unassigned)

Tracking

45 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [addon:???])

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161129173726

Steps to reproduce:

Compose a any new msg.

Had to downgrade going back to prior update, 45.6.0


Actual results:

Patches made in v. 45.7.0 appears to have created the scrolling issue. I can manually scroll when my compose reached the bottom of the window BUT it should automatically scroll as more text is added as it did in prior update.  v. 45.6.0 works fine. 

Dell T7400, 10Gb, Intel Xeon Quad Core, 1 TeraB


Expected results:

Page should scroll when composing after reaching window bottom as it did w 45.6.0

Dell T7400, 10Gb, Intel Xeon Quad Core, 1 TeraB

Comment 1

2 years ago
I don't quite understand the error report.

You compose a new message and enter a lot of text in many lines, when you get to the bottom of the text entry area, a scrollbar appears and the top scrolls out of view. The caret (insertion point) stays somewhere at the bottom but is visible as you type. That works fine for me.

Comment 2

2 years ago
John, doe sit happen in safe mode? https://support.mozilla.org/kb/safe-mode-thunderbird
Flags: needinfo?(JLJ)
(Reporter)

Comment 3

2 years ago
I noted the issue immediately upon update to 45.7.0 amd since have work to do reverted to 45.6.0 where issue did not exist. Since have updated to 45.8.0 which works properly. Result is don't know if it occurs in safe mode. This was months ago. I suggest that auto-upgrades skip 45.7.0 and go directly to 45.8.0, not waste time as the latter is most recent update anyway. 48.8.0 works as it should.

Comment: I know that an one of my extensions my have caused the issue as this sort of thing is common (in FF). Was not willing to spend time debugging TB extensions - I do when in FF b/c issues are most often much more disruptive than in TB. E.g.often particularly w TF&SC addon which conflicted w Reminderfox layout - fixed once but then has re-appeared w subsequent updates. Given up on that. Extension conflicts never-ending problem !!!

RECOMMENTS DISABLE 15.7.0 & force updates to current version.

- John

Comment 4

2 years ago
> Was not willing to spend time debugging TB extensions

this is why safe mode is such a valuable diagnostic tool - in a mere 2 minutes you can determine whether an addon is likely to have caused a problem, without touching any settings or guessing.

With several million users we don't have any other reports of this issue, so best estimate from a QA point of view is that thunderbird 45.7.0 was not at fault, but rather some addon was involved.

p.s. thank you for giving us an update and not abandoning your bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Component: Untriaged → Message Compose Window
Flags: needinfo?(JLJ)
Resolution: --- → INVALID
Whiteboard: [addon:???]
(Reporter)

Comment 5

2 years ago
Wayne - You are probably correct. Not that I would not take the time to verify the issue but rather that I no longer have that perticular version loaded which would require reloading a past version from the web to test it. My version of TB has the std GUI and would not have been an issue. My version of FF has a highly configured GUI using an addon, Clasic Theme Restorer, w some 30 other addons that are very important to me so do verify any issues w new versions in Safe Mode always: Addons which suddenly do not work properly w new versions are extemely annoying and often time coonsumeing. With TB it was just not important to spend the time b/c reloading just prior version was quick and extremely easy - despite having 16 extensions in my configuration. As you wrote, the issue was likely a conflicting extension/addoon....

Thanks for the follow-up.

Regards, John
You need to log in before you can comment on or make changes to this bug.