devtools/content/framework/connect/connect.css uses float: inline-end, will cause browser_parsable_css.js to permafail on Gecko 53 merge to beta on March 6th

RESOLVED FIXED in Firefox 53

Status

defect
RESOLVED FIXED
3 years ago
Last year

People

(Reporter: philor, Assigned: tomer)

Tracking

53 Branch
Firefox 54
Dependency tree / graph

Firefox Tracking Flags

(firefox51 unaffected, firefox52 unaffected, firefox53+ fixed, firefox54 fixed)

Details

Attachments

(1 attachment)

Same story as bug 1334956, no float: inline-* on Gecko 53 once it hits beta so both browser_parsable_css.js and the use of it will start to fail on 2017-03-07.

[Tracking Requested - why for this release]: permanently failing test, pulling of hair, rending of garments, when 53 merges to beta.
6th, 7th, one of those days. (6th, I just can't tell merge from release.)
Summary: devtools/content/framework/connect/connect.css uses float: inline-end, will cause browser_parsable_css.js to permafail on Gecko 53 merge to beta on March 7th → devtools/content/framework/connect/connect.css uses float: inline-end, will cause browser_parsable_css.js to permafail on Gecko 53 merge to beta on March 6th
Assignee: nobody → tomer.moz.bugs
Status: NEW → ASSIGNED
Comment on attachment 8831670 [details]
Bug 1334958 - devtools/content/framework/connect/connect.css uses float: inline-end

This should fix beta, unless you prefer to backout the change instead.
Attachment #8831670 - Flags: review?(jryans)
See Also: → 1335010
Comment on attachment 8831670 [details]
Bug 1334958 - devtools/content/framework/connect/connect.css uses float: inline-end

https://reviewboard.mozilla.org/r/108210/#review109302

Thanks!
Attachment #8831670 - Flags: review?(jryans) → review+
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/1509a4e1d8af
devtools/content/framework/connect/connect.css uses float: inline-end r=jryans
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/1509a4e1d8af
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 54
Please request Aurora approval on this at your earliest convenience :)
Flags: needinfo?(tomer.moz.bugs)
Comment on attachment 8831670 [details]
Bug 1334958 - devtools/content/framework/connect/connect.css uses float: inline-end

Approval Request Comment
[Feature/Bug causing the regression]: bug 1324118
[User impact if declined]: test failures
[Is this code covered by automated tests?]: no, but it cause failures due to unimplemented keywords.  
[Has the fix been verified in Nightly?]: yes.
[Needs manual test from QE? If yes, steps to reproduce]: probably not
[List of other uplifts needed for the feature/fix]: no dependencies beside bug 1324118 which this patch fix.
[Is the change risky?]: not too much.
[Why is the change risky/not risky?]: Just backporting CSS code to use :dir().
[String changes made/needed]:
Flags: needinfo?(tomer.moz.bugs)
Attachment #8831670 - Flags: approval-mozilla-aurora?
Comment on attachment 8831670 [details]
Bug 1334958 - devtools/content/framework/connect/connect.css uses float: inline-end

Fix test failures. Aurora53+.
Attachment #8831670 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Track 53+ as this will happen when merging to mozilla-beta.
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.