Sync is regularly crashing on Mac

RESOLVED DUPLICATE of bug 1309696

Status

()

Firefox
Sync
RESOLVED DUPLICATE of bug 1309696
a year ago
a year ago

People

(Reporter: AM, Unassigned)

Tracking

51 Branch
Unspecified
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

I login to firefox Sync. Firefox crashes after a short time (< 1min).

Firefox stable when sync is disabled by logging out

Seen on two different computers - recent macbook pro and  old macbook air


Actual results:

Crash ever since the update to maxos 10.12.3 (and ff51 the same day). Some examples ( I have others on other machines)

bp-4369fbce-2443-49d2-8db8-6dd162170130
	30/01/2017	07:39
bp-d7535680-9d06-462c-ae0e-2fb9c2170127
	27/01/2017	21:33
bp-6aef5d72-0d19-42eb-a2ac-80b792170127
	27/01/2017	21:32
bp-c4d350f2-1f20-43cb-8ef9-67c692170127
	27/01/2017	21:22
bp-e45873e1-b907-42c4-9792-a15702170127
	27/01/2017	21:20
bp-05b9b657-0835-4dfb-b8f4-739ce2170127
	27/01/2017	21:19
bp-3f8bf146-8409-40bb-815c-eca9f2170127
	27/01/2017	19:49
bp-a2db369f-a22f-425e-b4af-3c2ab2170127
	27/01/2017	19:49
bp-6fb756e4-a082-413e-b1ea-eb74b2170127
	27/01/2017	19:48
bp-f8f7eeb0-4a87-4ca5-8bb9-7dc5f2170127
	27/01/2017	19:48


Expected results:

No crash.

Note: I re-installed a fresh firefox, + did a full refresh. Some of the crashes were
without add-ons installed. Does not make a difference.

Updated

a year ago
Component: Untriaged → Sync
OS: Unspecified → Mac OS X
I've seen this kind of crash on macOS before, in https://bugzilla.mozilla.org/show_bug.cgi?id=1310554#c8. AM, do you have a lot of bookmarks?
Flags: needinfo?(augustmiles)
(Reporter)

Comment 2

a year ago
I must have a few thousand bookmarks.

However in the last days it crashes within minutes of every single use of firefox. This is new
and makes the program unusable with sync on.


Running without sync has been a revelation  (I always have it on) -- firefox feels far far more responsive compared to what I am used to.

Crash may well be linked to update to 10.12.3
Blocks: 1337321
Comment 1 implies this might be a database error in places.sqlite. That file has all your private history and bookmark information, but if you are willing to share this privately with one of us it might help narrow it down further. Seeing some sync logs [1] would also give us some insights. You could also try the "places maintenance" addon [2], which *might* repair the problem and let us proceed. 

[1] https://wiki.mozilla.org/CloudServices/Sync/File_a_desktop_bug
[2] https://bugzilla.mozilla.org/show_bug.cgi?id=1337321
(Reporter)

Comment 4

a year ago
My last sync error is over one month old, which is older than the instability.

I tried FF52 and 54 I get crashes

Going back to 49 all is stable again
(In reply to AM from comment #4)
> My last sync error is over one month old, which is older than the
> instability.
> 
> I tried FF52 and 54 I get crashes
> 
> Going back to 49 all is stable again

This is almost certainly because we changed how Sync access places.sqlite, causing crashes in your profile. Please see comment 3 for a few things that might be able to help.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(augustmiles)
Resolution: --- → DUPLICATE
Duplicate of bug: 1309696
(Reporter)

Comment 7

a year ago
I cleaned with "places maintenance". And the desktop instance of firefox (ff52beta) became stable!


Three hours later I opened my macbook (ff49), and the desktop copy crashed within seconds.
It then regularly crashed every minute or so as before.

bp-76bebedc-3698-40b9-8684-bb02d2170214

Rerunning maintenance, it became stable again. So it sounds a bit like a format incompatibility in the sync.

I see that a new version of sqlite will added. So I will now become silent and see how it goes forwards.

Nothing in
about:sync-log

Also I commented in bug 1309696. which I will use if I have anything further to add.
You need to log in before you can comment on or make changes to this bug.