Closed Bug 1335010 Opened 3 years ago Closed 3 years ago

mobile/android/themes/core/config.css uses float: inline-*

Categories

(Firefox for Android :: Theme and Visual Design, defect)

Unspecified
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 54
Tracking Status
firefox51 --- unaffected
firefox52 --- unaffected
firefox53 + fixed
firefox54 + fixed

People

(Reporter: tomer, Assigned: tomer)

References

()

Details

Attachments

(1 file)

… May cause test failures on beta and release while layout.css.float-logical-values.enabled is not enabled there.
Comment on attachment 8831679 [details]
Bug 1335010 - mobile/android/themes/core/config.css uses float: inline-*

https://reviewboard.mozilla.org/r/108232/#review109242
Attachment #8831679 - Flags: review?(s.kaspari) → review+
[Tracking Requested - why for this release]:
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/db25ecf790ee
mobile/android/themes/core/config.css uses float: inline-* r=sebastian
Keywords: checkin-needed
(In reply to Tomer Cohen :tomer from comment #3)
> [Tracking Requested - why for this release]:

This change is required for beta and up because layout.css.float-logical-values.enabled is preffed off and will cause test failures.
Tracking 53/54+ because it will cause test failures.
https://hg.mozilla.org/mozilla-central/rev/db25ecf790ee
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 54
Please request Aurora approval on this at your earliest convenience :)
Flags: needinfo?(tomer.moz.bugs)
Comment on attachment 8831679 [details]
Bug 1335010 - mobile/android/themes/core/config.css uses float: inline-*


Approval Request Comment
[Feature/Bug causing the regression]: bug 1298904
[User impact if declined]: test failures
[Is this code covered by automated tests?]: no, but it cause failures due to unimplemented keywords.  
[Has the fix been verified in Nightly?]: yes.
[Needs manual test from QE? If yes, steps to reproduce]: probably not
[List of other uplifts needed for the feature/fix]: no dependencies beside bug 1298904 which this patch fix.
[Is the change risky?]: not too much.
[Why is the change risky/not risky?]: Just backporting CSS code to use :dir().
[String changes made/needed]:
Flags: needinfo?(tomer.moz.bugs)
Attachment #8831679 - Flags: approval-mozilla-aurora?
Comment on attachment 8831679 [details]
Bug 1335010 - mobile/android/themes/core/config.css uses float: inline-*

Simple fix, broke in 53, let's uplift to aurora.
Attachment #8831679 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.