If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Flash 24.0.0.194 is not loading in non-e10s mode

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
8 months ago
7 months ago

People

(Reporter: StefanG_QA, Unassigned)

Tracking

54 Branch
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(firefox54 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 months ago
Created attachment 8831858 [details]
non-e10s AncientChina Flash does not load.PNG

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0 (20170130030205) 
Shockwave Flash Version: 24.0.0.194

STR
1. Launch Firefox Nightly in non-e10s mode
2. Navigate to https://airtightinteractive.com/demos/flash/stage3d/cubes/
3. Navigate to http://www.flare3d.com/demos/AncientChina/
4. Navigate to http://www.cnn.com/2016/10/10/us/weather-matthew/index.html
5. Verify all flash content loads

AR: Flash content is not loading in non-e10s mode
ER: Flash content should load in non-e10s mode

Note: Visit the above pages in e10s mode (everything loads smoothly)
dom.ipc.plugins.asyncdrawing.enabled = false does not solve the issue
(Reporter)

Comment 1

8 months ago
Created attachment 8831859 [details]
non-e10s Cubes does not load.PNG
(Reporter)

Updated

8 months ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64

Comment 2

7 months ago
Stefan, I missed triaging this when you filed it. Is this specific to content which uses Stage3D? And when you say "aunch Firefox Nightly in non-e10s mode" do you mean that you go into preferences, uncheck "Enable multi-process Nightly" and relaunch, or are you using the "New non-e10s window" button from the menu?
Flags: needinfo?(stefan.georgiev)
(Reporter)

Comment 3

7 months ago
I meant that I've unchecked "Enable multi-process Nightly" and relaunch the browser.
However now I cannot reproduce the issue on any of the listed pages, may be because of the Jim fixes or because of the new Flash update to 24.0.0.221.

I will mark the bug as Resolved:WFM.
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

7 months ago
Flags: needinfo?(stefan.georgiev)
You need to log in before you can comment on or make changes to this bug.