[Widevine] Amazon videos causing "The Widevine CDM plugin has crashed on Mac

RESOLVED WORKSFORME

Status

()

P1
normal
Rank:
15
RESOLVED WORKSFORME
2 years ago
a year ago

People

(Reporter: haik, Unassigned)

Tracking

51 Branch
Unspecified
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Filing this bug on behalf of Craig who commented about the problem on bug 1286480 comment 28+: https://bugzilla.mozilla.org/show_bug.cgi?id=1286480#c28

Copied from bug 1286480:

I seem to be having an extremely similar issue. Single upgrading to 50.1 Widevine always crashes on Amazon and Netflix. I just upgraded to 51 hoping it would fix the issue and I'm still getting constant crashes. I'm not sure what else to try. It is only Widevine that is crashing, other browsing behaves as normal.

1) No external monitor is attached. This is just direct from my MacBook Pro

2) This is a Console output surrounding a forced crash (attempting to play a Netflix title)
default	10:37:18.414567 +0000	plugin-container	subsystem: com.apple.coreaudio, category: ac, enable_level: 0, persist_level: 0, default_ttl: 0, info_ttl: 0, debug_ttl: 0, generate_symptoms: 0, enable_oversize: 0, privacy_setting: 2, enable_private_data: 0
default	10:37:18.415525 +0000	plugin-container	subsystem: com.apple.coreaudio, category: drc, enable_level: 0, persist_level: 0, default_ttl: 0, info_ttl: 0, debug_ttl: 0, generate_symptoms: 0, enable_oversize: 0, privacy_setting: 2, enable_private_data: 0
default	10:37:18.421542 +0000	plugin-container	ACMP4AACBaseDecoder.cpp:352:Initialize: (0x7fb5e4232640) Input format:  2 ch,  48000 Hz, 'aach' (0x00000000) 0 bits/channel, 0 bytes/packet, 2048 frames/packet, 0 bytes/frame
default	10:37:18.421717 +0000	plugin-container	ACMP4AACBaseDecoder.cpp:355:Initialize: (0x7fb5e4232640) Output format:  2 ch,  48000 Hz, Float32, inter
default	10:37:19.601487 +0000	opendirectoryd	Client: <private>, UID: 0, EUID: 0, GID: 0, EGID: 0
default	10:37:21.466308 +0000	kernel	IO80211Interface::updateReport _peerManager is missing

default	10:37:23.017438 +0000	opendirectoryd	Client: <private>, UID: 0, EUID: 0, GID: 0, EGID: 0
default	10:37:23.018525 +0000	opendirectoryd	Client: <private>, UID: 0, EUID: 0, GID: 20, EGID: 20
default	10:37:23.020181 +0000	opendirectoryd	Client: <private>, UID: 501, EUID: 501, GID: 20, EGID: 20
default	10:37:23.045740 +0000	opendirectoryd	Client: <private>, UID: 501, EUID: 501, GID: 20, EGID: 20
default	10:37:30.623253 +0000	opendirectoryd	Client: <private>, UID: 501, EUID: 501, GID: 20, EGID: 20
default	10:37:30.679981 +0000	kernel	AMFI: allowing exception handler for 'plugin-container' (17045) because it is handling itself.
default	10:37:32.094788 +0000	CommCenter	#watchdog #I Callback Watchdog: checkin 7434
default	10:37:32.095067 +0000	CommCenter	#watchdog #I Server Watchdog: checkin 7434
default	10:37:33.069148 +0000	opendirectoryd	Client: <private>, UID: 0, EUID: 0, GID: 0, EGID: 0
default	10:37:33.069971 +0000	opendirectoryd	Client: <private>, UID: 0, EUID: 0, GID: 20, EGID: 20
default	10:37:33.071153 +0000	opendirectoryd	Client: <private>, UID: 501, EUID: 501, GID: 20, EGID: 20
default	10:37:33.093426 +0000	opendirectoryd	Client: <private>, UID: 501, EUID: 501, GID: 20, EGID: 20

3) about:support output
{
  "application": {
    "name": "Firefox",
    "osVersion": "Darwin 16.4.0",
    "version": "51.0.1",
    "buildID": "20170125094131",
    "userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:51.0) Gecko/20100101 Firefox/51.0",
    "safeMode": false,
    "updateChannel": "release",
    "supportURL": "https://support.mozilla.org/1/firefox/51.0.1/Darwin/en-US/",
    "numTotalWindows": 1,
    "numRemoteWindows": 1,
    "remoteAutoStart": true,
    "autoStartStatus": 1
  },
  "modifiedPreferences": {
    "accessibility.typeaheadfind.flashBar": 0,
    "browser.cache.frecency_experiment": 1,
    "browser.cache.disk.smart_size.first_run": false,
    "browser.cache.disk.smart_size.use_old_max": false,
    "browser.cache.disk.capacity": 358400,
    "browser.cache.disk.filesystem_reported": 1,
    "browser.download.importedFromSqlite": true,
    "browser.places.smartBookmarksVersion": 8,
    "browser.sessionstore.upgradeBackup.latestBuildID": "20170125094131",
    "browser.startup.homepage_override.buildID": "20170125094131",
    "browser.startup.homepage_override.mstone": "51.0.1",
    "browser.tabs.remote.autostart.2": true,
    "browser.tabs.drawInTitlebar": false,
    "browser.urlbar.lastSuggestionsPromptDate": 20170114,
    "browser.urlbar.daysBeforeHidingSuggestionsPrompt": 0,
    "dom.push.userAgentID": "30f5ef1d8ecf4fc586ba6059a8f725f3",
    "extensions.lastAppVersion": "51.0.1",
    "font.internaluseonly.changed": true,
    "media.gmp-manager.buildID": "20170125094131",
    "media.gmp.storage.version.observed": 1,
    "media.benchmark.vp9.versioncheck": 1,
    "media.gmp-gmpopenh264.lastUpdate": 1484137798,
    "media.gmp-widevinecdm.lastUpdate": 1484137799,
    "media.gmp-gmpopenh264.version": "1.6",
    "media.benchmark.vp9.fps": 210,
    "media.gmp-gmpopenh264.abi": "x86_64-gcc3-u-i386-x86_64",
    "media.gmp-manager.lastCheck": 1485599849,
    "media.gmp-widevinecdm.version": "1.4.8.903",
    "media.gmp-widevinecdm.abi": "x86_64-gcc3-u-i386-x86_64",
    "network.cookie.prefsMigrated": true,
    "network.predictor.cleaned-up": true,
    "places.database.lastMaintenance": 1485507323,
    "places.history.expiration.transient_current_max_pages": 106842,
    "plugin.importedState": true,
    "plugin.disable_full_page_plugin_for_types": "application/pdf",
    "services.sync.declinedEngines": "forms,history,passwords,prefs,addons,adblockplus",
    "services.sync.lastPing": 1485515774,
    "services.sync.lastSync": "Sat Jan 28 2017 10:38:16 GMT+0000 (GMT)",
    "services.sync.numClients": 2,
    "services.sync.engine.prefs": false,
    "services.sync.engine.addons": false,
    "services.sync.engine.passwords": false,
    "services.sync.engine.prefs.modified": false,
    "services.sync.engine.history": false,
    "storage.vacuum.last.places.sqlite": 1484167903,
    "storage.vacuum.last.index": 1
  },
  "lockedPreferences": {},
  "javaScript": {
    "incrementalGCEnabled": true
  },
  "accessibility": {
    "isActive": false,
    "forceDisabled": 0
  },
  "libraryVersions": {
    "NSPR": {
      "minVersion": "4.13.1",
      "version": "4.13.1"
    },
    "NSS": {
      "minVersion": "3.28.1",
      "version": "3.28.1"
    },
    "NSSUTIL": {
      "minVersion": "3.28.1",
      "version": "3.28.1"
    },
    "NSSSSL": {
      "minVersion": "3.28.1",
      "version": "3.28.1"
    },
    "NSSSMIME": {
      "minVersion": "3.28.1",
      "version": "3.28.1"
    }
  },
  "userJS": {
    "exists": false
  },
  "crashes": {
    "submitted": [
      {
        "id": "bp-430f9387-e690-44e2-84fb-495d82170125",
        "date": 1485343168000,
        "pending": false
      }
    ],
    "pending": 4
  },
  "sandbox": {},
  "extensions": [
    {
      "name": "Adblock Plus",
      "version": "2.8.2",
      "isActive": true,
      "id": "{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}"
    },
    {
      "name": "Application Update Service Helper",
      "version": "1.0",
      "isActive": true,
      "id": "aushelper@mozilla.org"
    },
    {
      "name": "Multi-process staged rollout",
      "version": "1.7",
      "isActive": true,
      "id": "e10srollout@mozilla.org"
    },
    {
      "name": "Pocket",
      "version": "1.0.5",
      "isActive": true,
      "id": "firefox@getpocket.com"
    },
    {
      "name": "Reddit Enhancement Suite",
      "version": "5.2.2",
      "isActive": true,
      "id": "jid1-xUfzOsOFlzSOXg@jetpack"
    },
    {
      "name": "Web Compat",
      "version": "1.0",
      "isActive": true,
      "id": "webcompat@mozilla.org"
    },
    {
      "name": "Adobe Acrobat - Create PDF",
      "version": "1.2",
      "isActive": false,
      "id": "web2pdfextension@web2pdf.adobedotcom"
    }
  ],
  "experiments": [],
  "graphics": {
    "numTotalWindows": 1,
    "numAcceleratedWindows": 1,
    "windowLayerManagerType": "OpenGL",
    "windowLayerManagerRemote": true,
    "supportsHardwareH264": "Yes",
    "currentAudioBackend": "audiounit",
    "adapterDescription": "",
    "adapterVendorID": "0x10de",
    "adapterDeviceID": "0x0fe9",
    "adapterRAM": "",
    "adapterDrivers": "",
    "driverVersion": "",
    "driverDate": "",
    "webglRenderer": "NVIDIA Corporation -- NVIDIA GeForce GT 750M OpenGL Engine",
    "webgl2Renderer": "NVIDIA Corporation -- NVIDIA GeForce GT 750M OpenGL Engine",
    "info": {
      "AzureCanvasBackend": "skia",
      "AzureCanvasAccelerated": 1,
      "AzureFallbackCanvasBackend": "none",
      "AzureContentBackend": "skia",
      "ApzWheelInput": 1,
      "TileHeight": 1024,
      "TileWidth": 1024
    },
    "featureLog": {
      "features": [
        {
          "name": "HW_COMPOSITING",
          "description": "Compositing",
          "status": "available",
          "log": [
            {
              "type": "default",
              "status": "available"
            }
          ]
        },
        {
          "name": "OPENGL_COMPOSITING",
          "description": "OpenGL Compositing",
          "status": "available",
          "log": [
            {
              "type": "default",
              "status": "available"
            }
          ]
        }
      ],
      "fallbacks": []
    },
    "crashGuards": []
  }
}

4) http://i.imgur.com/ZT2Mac2.png

Updated

2 years ago
Rank: 15
Priority: -- → P1
(Reporter)

Comment 1

2 years ago
Craig, thanks for providing that info. A couple more requests:

1) Which model Mac Book Pro?

2) Would you be willing to test Firefox Beta build 52 or Firefox Developer Edition build 53?

Some other notes:

From the crash report in your about:support (https://crash-stats.mozilla.com/report/index/430f9387-e690-44e2-84fb-495d82170125), we see this crash is in mozilla::gmp::GMPChild::ProcessingError which is pretty generic. The crash report links to a few other bugs, but none of them look related.
Flags: needinfo?(cmandrews85)

Comment 2

2 years ago
Hi Haik,
I really appreciate the help here.

1) MacBook Pro (Retina, 15 inch, Late 2013) on Sierra 10.12.3
2.3GHz Intel Core i7
16 GB 1600MHz DDR3
NVIDIA GeForce GT 750M 2048 MB / Intel Iris Pro 1536 MB 

2) Definitely. I'll pull down 52.0b2 now to test.

Note:
I forced another crash with the current 51 release: https://crash-stats.mozilla.com/report/index/79f60749-bfa8-4d22-8311-99ee42170131 in case it has any more info
Flags: needinfo?(cmandrews85)
(Reporter)

Comment 4

2 years ago
There have been some fixes in our Widevine support for streaming issues found on Amazon.com during the last month and it might be worth giving this another test (with Nightly build 54) to see if they addressed your problem.

Comment 5

2 years ago
(In reply to Haik Aftandilian [:haik] from comment #4)
> There have been some fixes in our Widevine support for streaming issues
> found on Amazon.com during the last month and it might be worth giving this
> another test (with Nightly build 54) to see if they addressed your problem.

Hello Haik,
Nightly 54 appears to have resolved the issue. I tested it with Netflix and Widevine CDM is no longer crashing. Thanks to all involved for the fixes and I'm looking forward to these changes making their way into the public release.

Cheers,
Craig
(Reporter)

Comment 6

a year ago
(In reply to Craig from comment #5)
> (In reply to Haik Aftandilian [:haik] from comment #4)
> > There have been some fixes in our Widevine support for streaming issues
> > found on Amazon.com during the last month and it might be worth giving this
> > another test (with Nightly build 54) to see if they addressed your problem.
> 
> Hello Haik,
> Nightly 54 appears to have resolved the issue. I tested it with Netflix and
> Widevine CDM is no longer crashing. Thanks to all involved for the fixes and
> I'm looking forward to these changes making their way into the public
> release.

This appears to be a duplicate of a bug that was fixed in build 54 given that it's no longer reproducible. Closing as "Works for me" because we don't know which bug.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.