[EME] Add pref to override EME decrypt/decode with blank decoder

RESOLVED FIXED in Firefox 54

Status

()

P3
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: cpearce, Assigned: cpearce)

Tracking

unspecified
mozilla54
Points:
---

Firefox Tracking Flags

(firefox54 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
In order to identify whether there's a problem with audio or video decryption, it would be useful to have a pref to switch the audio decrypt & decode path to be overridden by a blank decoder. Then we can turn off one of audio or video, and see if a bug still occurs, effectively determining whether the problem is in the audio or video decrypt and decode.
Comment hidden (mozreview-request)

Comment 2

2 years ago
mozreview-review
Comment on attachment 8831921 [details]
Bug 1335295 - [EME] Add pref to override EME decrypt/decode with blank decoder.

https://reviewboard.mozilla.org/r/108406/#review110268

weird.. I'm certain I had r+ that one couple of days ago...
Attachment #8831921 - Flags: review?(jyavenard) → review+

Comment 3

2 years ago
Pushed by cpearce@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f727429bff74
[EME] Add pref to override EME decrypt/decode with blank decoder. r=jya

Comment 4

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/f727429bff74
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox54: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
You need to log in before you can comment on or make changes to this bug.