Closed Bug 1335306 Opened 3 years ago Closed 3 years ago

Record active keyboard layout name at crashing in NativeKey::GetFollowingCharMessage()

Categories

(Core :: Widget: Win32, defect)

All
Windows
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla54
Tracking Status
firefox52 --- fixed
firefox53 --- fixed
firefox54 --- fixed

People

(Reporter: masayuki, Assigned: masayuki)

References

Details

Attachments

(1 file)

We should record active keyboard layout name into crash report when it crashes in NativeKey::GetFollowingCharMessage(). This may help us to investigate what happen with such odd keyboard layouts.
Comment on attachment 8832036 [details]
Bug 1335306 Append active keyboard layout information into crash report when NativeKey crashes due to detecting impossible case caused by 3rd party's keyboard layout or utils

https://reviewboard.mozilla.org/r/108448/#review109788
Attachment #8832036 - Flags: review?(m_kato) → review+
Pushed by masayuki@d-toybox.com:
https://hg.mozilla.org/integration/autoland/rev/be78084e5b72
Append active keyboard layout information into crash report when NativeKey crashes due to detecting impossible case caused by 3rd party's keyboard layout or utils r=m_kato
Comment on attachment 8832036 [details]
Bug 1335306 Append active keyboard layout information into crash report when NativeKey crashes due to detecting impossible case caused by 3rd party's keyboard layout or utils

Approval Request Comment
[Feature/Bug causing the regression]: Collecting more detail of broken keyboard layout handling.
[User impact if declined]: We're struggling with bug 962140 which is caused by odd keyboard layout or utility. The crash is still reproduced only with Beta or Release users. So, I'd like to collect more information from them to fix most crashes on 52.
[Is this code covered by automated tests?]: No, this is just appending keyboard layout name to crash report when NativeKey crashes due to detecting odd result.
[Has the fix been verified in Nightly?]: I confirmed each |nsPrintfCString info| with a lot of keyboard layouts.
[Needs manual test from QE? If yes, steps to reproduce]: No.
[List of other uplifts needed for the feature/fix]: No.
[Is the change risky?]: No.
[Why is the change risky/not risky?]: Because this just adding a new information of active keyboard layout to the crash report.
[String changes made/needed]: No.

FYI: After this landing is released on Beta, I'd like to land some patches to prevent the crashes. Before preventing the crashes, I'd like to collect the hints to handle the odd keyboard layouts.
Attachment #8832036 - Flags: approval-mozilla-beta?
Attachment #8832036 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/be78084e5b72
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
Comment on attachment 8832036 [details]
Bug 1335306 Append active keyboard layout information into crash report when NativeKey crashes due to detecting impossible case caused by 3rd party's keyboard layout or utils

add keyboard layout info in some crash reports, aurora53+, beta52+
Attachment #8832036 - Flags: approval-mozilla-beta?
Attachment #8832036 - Flags: approval-mozilla-beta+
Attachment #8832036 - Flags: approval-mozilla-aurora?
Attachment #8832036 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.