Closed Bug 1335337 Opened 3 years ago Closed 3 years ago

Remove nsNativeTheme::IsButtonTypeMenu

Categories

(Core :: Layout: Form Controls, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla54
Tracking Status
firefox54 --- fixed

People

(Reporter: annevk, Assigned: mstange)

References

Details

Attachments

(1 file)

<button type=menu>test</button> has special rendering on macOS due to nsNativeTheme::IsButtonTypeMenu existing. That's a bug. Potentially a leftover from an earlier removal?

Discovered in https://github.com/whatwg/html/issues/237.
This is a regression from bug 508724.
Blocks: 508724
Attachment #8836148 - Flags: review?(enndeakin)
Attachment #8836148 - Flags: review?(enndeakin) → review+
Pushed by mstange@themasta.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/370de9349dd0
Restrict special <button type="menu"> theming to XUL <button> elements. r=Enn
https://hg.mozilla.org/mozilla-central/rev/370de9349dd0
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
Assignee: nobody → mstange
You need to log in before you can comment on or make changes to this bug.