CSS perspective and/or transform property bug in FF 51.0.1

RESOLVED DUPLICATE of bug 1316236

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 1316236
a year ago
a year ago

People

(Reporter: Stefanie, Unassigned)

Tracking

({testcase})

51 Branch
x86
Windows 10
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

On our website, we have a 3D cube ad which rotates after 1 sec. In Firefox 51, the ad totally disappeared.


Actual results:

I made a test on Codepen and saw that the perspective property totally ruins the transform. See it here: http://codepen.io/cat-a-flame/pen/WRMQjV


Expected results:

Check the codepen link in Chrome and you'll what should happen. (The black span supposed to slip a bit down with 22 pixels.
(Reporter)

Updated

a year ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86

Comment 1

a year ago
I did not find a working version of Firefox.
Component: Untriaged → Layout
Keywords: testcase
Product: Firefox → Core

Comment 2

a year ago
It looks fixed (maybe partially) with Aurora/Nightly.


Stefanie, could you install Aurora and confirm if it's fixed or not on your side.
https://www.mozilla.org/en-US/firefox/developer/all/
Flags: needinfo?(lullaby)
(Reporter)

Comment 3

a year ago
(In reply to Loic from comment #2)
> It looks fixed (maybe partially) with Aurora/Nightly.
> 
> 
> Stefanie, could you install Aurora and confirm if it's fixed or not on your
> side.
> https://www.mozilla.org/en-US/firefox/developer/all/

Yes, it works! Weird, how come this got buged only in 51?

Comment 4

a year ago
It has been fixed by:
Xidorn Quan — Bug 1316236 - Treat perspective(0) as perspective(infinity). r=dholbert

https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=bd0cd9af94d9334b862d9891013fed56fb9b3b7c&tochange=ad8896084074234320bd2656ab782410a0f8120d

Xidorn, is there some tests for your patch to extract from the testcase provided by the reporter?
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(lullaby) → needinfo?(xidorn+moz)
Resolution: --- → DUPLICATE
Duplicate of bug: 1316236
> Yes, it works! Weird, how come this got buged only in 51?

perspective(0) was invalid before 51 per spec at that moment, and it is treated as perspective(infinity) since 52 per CSSWG resolution two weeks ago to follow other browsers. I tried to make it uplift to 51, but that time was too close to 51's release, so I failed.

Basically, perspective(0) was treated as perspective(epsilon) in Firefox 51, per suggestion from a spec editor. But CSSWG eventually decided that we need to treat it as perspective(infinity), rather than the more sensible perspective(epsilon), for web compatibility.

> Xidorn, is there some tests for your patch to extract from the testcase provided by the reporter?

I think the testcase added in bug 1316236 covers the case here.
Flags: needinfo?(xidorn+moz)
(Reporter)

Comment 6

a year ago
(In reply to Xidorn Quan [:xidorn] (UTC+10) from comment #5)
> > Yes, it works! Weird, how come this got buged only in 51?
> 
> perspective(0) was invalid before 51 per spec at that moment, and it is
> treated as perspective(infinity) since 52 per CSSWG resolution two weeks ago
> to follow other browsers. I tried to make it uplift to 51, but that time was
> too close to 51's release, so I failed.
> 
> Basically, perspective(0) was treated as perspective(epsilon) in Firefox 51,
> per suggestion from a spec editor. But CSSWG eventually decided that we need
> to treat it as perspective(infinity), rather than the more sensible
> perspective(epsilon), for web compatibility.
> 
> > Xidorn, is there some tests for your patch to extract from the testcase provided by the reporter?
> 
> I think the testcase added in bug 1316236 covers the case here.

I see, thank you for the detailed answer!
You need to log in before you can comment on or make changes to this bug.