WebDAV Launcher add-on not working since version 51.xx (50.xx?)

RESOLVED WORKSFORME

Status

()

Firefox
Extension Compatibility
RESOLVED WORKSFORME
a year ago
a year ago

People

(Reporter: juergen.k.schwarz, Unassigned)

Tracking

51 Branch
x86
Windows 10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170124094647

Steps to reproduce:

I tried to edit a MS-Office document attached to a confluence-page with the "edit document"/"edit in office" - function of atlassian confluence.


Actual results:

I got a prompt to install the required plugin (WebDAV Launcher):

"A plugin is required to use this feature. Would you like to download it?"

The plugin is already installed and configured with the correct pathes to MS-Office.


Expected results:

The addon should launch the MS-Office-Program (Word/Excel/...) which opens the chosen document as editable - as it was before ...
(Reporter)

Updated

a year ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86

Comment 1

a year ago
On https://addons.mozilla.org/en-US/firefox/addon/webdav-launcher/:
Version 1.1.0 doesn't work with Firefox 51.0.1 in Confluence Rated 1 out of 5 stars

by Anonymous user 10de53 on January 31, 2017 · permalink · translate

Opening a file from Confluence via WebDav Plugin doesn't work aufter Update to Version 1.1.0. errorMessage: A plugin is required to use this feature. Would you like to download it?
After Downgrade to 1.0.8.1-signed it works like before...


Do you try the Downgrade to 1.0.8.1-signed?
Component: Untriaged → Extension Compatibility
Flags: needinfo?(juergen.k.schwarz)

Comment 2

a year ago
Is this add-on e10s-ready? The latest version is from Jan. 2016, it needs probably an update.
(Reporter)

Comment 3

a year ago
@Yang: Thanks. I changed from ver 1.1.0 to 1.0.8.1-signed and disabled the automated update. Worked at first try at home with Firefox 50.0.1 (32bit) and confluence 5.7.3.

I'll try tomorrow morning at work too.

@Loic: I found no update for the 1.1.0 unsigned version, no hints at the atlassian website. And I have a question (I'm new here in the bugzilla area :-)). What does e10s-ready mean?
Flags: needinfo?(juergen.k.schwarz)
(Reporter)

Comment 4

a year ago
@Yang: The link on addons.mozilla.com you refer to - the cited entry seems to be posted after my visit on the addon-homepage this morning. I just saw the second one ...

Comment 5

a year ago
e10s = multiprocess.

Comment 6

a year ago
Is there a public demo of Confluence to reproduce the bug easily?

if that's the case, we can narrow down a regression range and find the bug which broke the add-on. It might be a bug about a change in the API of FF51, so in that's case, the devs of the add-on need to update it.

Comment 7

a year ago
Juergen, if you have some time, could you report the issue to the Atlassian dev team and ask them if they could update their add-on, please.
(Reporter)

Comment 8

a year ago
Loic, thanks for your support. A public demo of confluence is available as a 30 days trial software for setting up an own server - but the problem I've had is correlated to a confluence plugin, the so called office-connector. I 'm not sure if it's included in the trial package, so probably it's not so easy to reproduce the bug. The webdav-addon is necessary for working with Firefox - the IE is working without it.

I had the idea to inform atlassian too and I will do this in the next days. I'm sure I'm not the only one who was concerned by this malfunction ... ;-)
(Reporter)

Comment 9

a year ago
Loic, thanks for your support. A public demo of confluence is available as a 30 days trial software for setting up an own server - but the problem I've had is correlated to a confluence plugin, the so called office-connector. I 'm not sure if it's included in the trial package, so probably it's not so easy to reproduce the bug. The webdav-addon is necessary for working with Firefox - the IE is working without it.

I had the idea to inform atlassian too and I will do this in the next days. I'm sure I'm not the only one who was concerned by this malfunction ... ;-)

My support for my colleagues at work tommorrow morning was successful - the downgrade fixed the problem on 6 PC's with different software and add-on-configurations (all with WIN10 as OS).

So I'll change the status to "Resolved" with "Worksforme".
(Reporter)

Updated

a year ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.