Table layout gets munged when window resized and then page refreshed.

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: Pablo Mayrgundter, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
There's a little box inlined with the story called "Times News Tracker". 
There's 3 buttons in it whose placement gets munged when you:

- start the browser in non-full-screen
- go to the page (buttons are laid or correctly)
- maximize the window
- refresh the page

now those buttons are floating over the text instead.

NOTE: you have to have a NYTimes account to get to this page.

Comment 1

17 years ago
From: chrisk@mit.edu

I see this with v0.9.9 on Windows 2000
Where: From the http://www.nytimes.com/pages/opinion/index.html
page, read any article.  (free reg. required)

The 4 button in the Times News Tracker (in the right column)
are always drawn a few inches to high on the page.

The button can be clicked where they are drawn OR in the
empty locations where they should have been drawn.

Another rendering issue:  If I made the windows too narrow (e.g. 1/2 as wide
as the content) then almost every time I press reload the whitespace
between paragraphs in the main article below the height of the Times News
Tracker box gets rendered as a black background instead of white.  Scrolling
left and right redraws that whitespace with the correct white background.
Whitespace before the vertical position of the news tracker is never
drawn incorrectly.  Coincidence?

Comment 2

16 years ago
I'm seeing a similar behavior.  Tables are created in an xslt stylesheet, with a
thumbnail image in the leftmost col of each <tr>, when the thumbnail finishes
loading the first row jumps on top on the row on top of it (with <th>'s)... so
the transformed output looks like this:

<table>
 <tr>
  <th>..</th>
  <th>..</th>
  <th>..</th>
 </tr>
 <tr>
  <td><img src="..."/></td>
  <td>..</td>
  <td>..</td>
 </tr>
</table>

and I'm attaching a screenshot of what mozilla does with it.  Now, if I resize
the window hoizontally (the table isn't close to reaching the far right of the
screen), it corrects it self.  

Comment 3

16 years ago
Created attachment 87103 [details]
screenshot of faulty table rendering
reporter (Pablo Mayrgundter): can you reproduce this bug with a recent build of
mozilla (for example, 1.1beta)? if so, please comment again with details. if
not, please resolve this bug as WORKSFORME. thanks.
no answer.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.