borders wrong in RSS preview interface

RESOLVED WONTFIX

Status

()

Toolkit
Themes
RESOLVED WONTFIX
7 months ago
3 months ago

People

(Reporter: uoggegloo, Unassigned)

Tracking

({regression})

43 Branch
All
Linux
regression
Points:
---

Firefox Tracking Flags

(firefox51 wontfix, firefox52 affected, firefox53 affected, firefox54 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 months ago
Created attachment 8832118 [details]
top is from FF 42 (good); bottom is from later version (bad)

in bug 1187203, comment 28, `-moz-appearance: -moz-gtk-info-bar` was added to RSS feed CSS on linux; this messed up the borders for #feedHeaderContainer in the RSS preview interface ...

In the theme I use ("TraditionalOk" in Mate Desktop), the side borders are missing, the bottom border color doesn't match the border color for #feedBody, and the border-radius declaration isn't respected (see comparison screen capture).

Interestingly, Inspector shows the missing styles as active, however, I can only see them when I disable `-moz-appearance: -moz-gtk-info-bar`

regression range:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=22c34579ae0720e7d3dc39a22b9d33f13bc0198b&tochange=8a6045d14d6bd348a3b5bfeb55a9321e680cc93e

specifically, I believe it's:
https://hg.mozilla.org/mozilla-central/rev/ea072f95e28e
(Reporter)

Updated

7 months ago
Blocks: 1187203
Has Regression Range: --- → yes
Keywords: regression

Comment 1

7 months ago
Ty for the bug report and the regression range.
status-firefox51: --- → affected
status-firefox52: --- → affected
status-firefox53: --- → affected
status-firefox54: --- → affected
Karl, can you please take a look since Andrew isn't available these days?
Status: UNCONFIRMED → NEW
status-firefox51: affected → wontfix
Ever confirmed: true
Flags: needinfo?(karlt)
Thanks for the detailed report, but I think this is wontfix because the intention is to draw the notification element like a native info bar, and I think this is what was intended from this in TraditionalOk 3.18.3:

GtkInfoBar:last-child,
.info:last-child,
.warning:last-child,
.question:last-child,
.error:last-child {
        /* only apply a border on the last infobar if
         * there's more than one packed in */
        border-bottom-width: 1px;
        border-style: solid;
}

.info > * {
        background-color: @info_bg_color;
        color: @info_fg_color;
        border-color: darker(@info_bg_color);
}

-moz-appearance typically overrides border and background in UA style sheets.

(Oddly "Info Bars" in gtk3-demo 3.18.9 does not show the backgrounds, presumably because the child of .info is a GtkRevealer (since 3.10), which does not draw a background, in that version of GTK.)
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Flags: needinfo?(karlt)
Resolution: --- → WONTFIX

Updated

7 months ago
Component: Widget: Gtk → Themes
Product: Core → Toolkit

Updated

3 months ago
Depends on: 1365669

Updated

3 months ago
No longer depends on: 1365669
You need to log in before you can comment on or make changes to this bug.