Closed Bug 1335511 Opened 5 years ago Closed 3 years ago

eMoney site rejects Firefox

Categories

(Web Compatibility :: Desktop, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: sfink, Unassigned)

Details

(Whiteboard: [needsdiagnosis])

I have an account at http://www.emoneyadvisor.com/ via a financial institution. Their website rejects the Firefox UA. My channel for support questions goes through my financial adviser to eMoney, and when I complained about lack of Firefox support, the response was

"I got the answer from eMoney support, they do not support Firefox, only Chrome and Internet Explorer. I am sorry for the inconvenience. Please let me know if you need help with other issues."

I tried with the IE11 UA string, and everything I've tried so far has worked fine. The above reply makes me wonder about Edge and Safari.
Thanks for the report Steve. Dennis, would you mind taking a look at the cause of this (they have a free trial)?

If it's a purely server-side UA check, let's go ahead and spoof the UA via our gofaster addon and then attempt to work with the site to get it fixed.
Flags: needinfo?(dschubert)
Whiteboard: [needsdiagnosis]
The "free trail" apparently needs to get approved by their team:

> Your request has been received. An eMoney representative will be in touch shortly.

Will follow-up as soon as I get access.
Flags: needinfo?(dschubert)
I'm a little confused by the behavior I've seen since I filed this. The next time I tried it, it seemed to let me login even though I was using Firefox (with the default user agent). But this morning, it sent me to a blank screen with the default user agent. Switching to IE11 made it work. Also, it seems to only check during login; I can revert to the default user agent while using the site and it seems to let me through.
Dennis, did they ever send you that account?
Flags: needinfo?(dschubert)
I sent them a reminder last Friday, haven't heard anything so far. :/
Flags: needinfo?(dschubert)
Priority: -- → P3
(In reply to Steve Fink [:sfink] [:s:] from comment #3)
> I'm a little confused by the behavior I've seen since I filed this. The next
> time I tried it, it seemed to let me login even though I was using Firefox
> (with the default user agent). But this morning, it sent me to a blank
> screen with the default user agent. Switching to IE11 made it work. Also, it
> seems to only check during login; I can revert to the default user agent
> while using the site and it seems to let me through.

I wonder if a cookie gets set and it stops caring about UA strings at that point.

Steve, is this still a problem? Sorry we haven't made any traction here.
Flags: needinfo?(sphink)
It seems to be working now.

I thought it might be because I have User-Agent Switcher installed, but it appears that it wasn't active for that site anyway. And I've been using the site successfully for a while now.

I tried disabling the extension and logging back in. It still works.

Thanks for looking into it!
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(sphink)
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.