Update to 51 + Refresh = Sync not working with Addons/Extensions

RESOLVED WORKSFORME

Status

()

Firefox
Sync
RESOLVED WORKSFORME
a year ago
a year ago

People

(Reporter: tkchan007, Unassigned)

Tracking

51 Branch
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.76 Safari/537.36

Steps to reproduce:

Firefox prompt to restart to update to latest version (51).  Which I normally do by following up with a Refresh.  Normally sync will then reinstall all the plugins and extensions but this time it doesn't.  In fact, after sitting there for a while (sync icon spinning), Firefox proceed to crash.

Uninstalled Firefox, wiped the old folders in c:\Program Files (x86)\Mozilla\Firefox\ and reinstall Firefox 51 from new download repeat the same exact issue.


Actual results:

Sync doesn't install Addons and Extensions.  And then Firefox crash sometime after.


Expected results:

Addons and Extensions should be reinstalled by Sync.
(Reporter)

Updated

a year ago
Component: Untriaged → Sync
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
I'm sorry, that's really frustrating. Some questions for you:

* Are you able to interact with the Firefox UI while it's syncing, or does it freeze and then crash?
* Do you see the Crash Reporter after Firefox crashes, have you reported the crash, and do you have a link to that report?
* Does it still crash if you set up a new profile (https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles) and then connect that profile to Sync?
* How many add-ons and extensions do you have?
* Do you use sync for bookmarks and history, too? If so, how many bookmarks you have?

Unfortunately, I don't really recommend running Refresh with Sync enabled; it's known to act up occasionally (bug 1311091, bug 1124553). We're hoping to make this more robust next quarter.
Flags: needinfo?(tkchan007)
From triage meeting: Could QA try to reproduce this issue?
Flags: needinfo?(kkumari)

Comment 3

a year ago
I tried reproducing this issue with different user agents, profile with many addons, on current release channel, upgrading old Firefox channel with refresh & sync enabled but couldn't reproduce this.
Flags: needinfo?(kkumari)
Thanks Kanchan! Given there's been no response from the user and that we can't reproduce it, I'm closing this as WFM. tkchan007, please feel free to reopen this if you can provide more information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(tkchan007)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.