WebSocket data using per message deflate arrives as garbage

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: Dominic Szablewski, Unassigned)

Tracking

51 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.76 Safari/537.36

Steps to reproduce:

Visit http://phoboslab.org/files/bugs/node-ws/





Actual results:

The 2nd line the textarea will read "Fail: data at 0 is 66 (received 4 bytes)"


Expected results:

2nd line in the textarea should read "Succes: all zeroes (received 16 bytes)"

What went wrong?
A WebSocket server sends out 3 message with raw bytes, all 0, using per message deflate. 1st and 3rd messages are compressed, 2nd is not. The 2nd, uncompressed message, arrives as garbage.

The test case reliably fails in Chrome & Firefox but works without any problems in Edge and Safari. 

Firefox 51 Windows & OSX: fail
Chrome 56 Windows & OSX: fail
Safari 10 OSX: success
Edge Windows: success

Related Chromium Bug: https://bugs.chromium.org/p/chromium/issues/detail?id=687378
(Reporter)

Comment 1

a year ago
Seems to be a bug in the server after all: https://github.com/websockets/ws/issues/983#issuecomment-276587439
Marking this as Resolved-Invalid based on comment 1.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.