URI with question mark includes question mark in search term

RESOLVED DUPLICATE of bug 1334019

Status

()

RESOLVED DUPLICATE of bug 1334019
2 years ago
2 years ago

People

(Reporter: wizzwizz4, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

1. Select address bar.
2. Enter string that looks like a search term, beginning with QUESTION MARK.
3. Submit search.


Actual results:

The literal string that is entered into the address bar, including the question mark, is searched.


Expected results:

The string that is entered into the address bar, sans the question mark, is searched. (This was old behaviour iirc.)

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1334019
You need to log in before you can comment on or make changes to this bug.