[ShowFor] showfor.js is broken on kitsune and lithium

RESOLVED INVALID

Status

support.mozilla.org - Lithium
Knowledge Base Software
P1
normal
RESOLVED INVALID
9 months ago
3 months ago

People

(Reporter: rolandtanglao, Assigned: rolandtanglao)

Tracking

Details

(Whiteboard: [1st2weeks])

+++ This bug was initially created as a clone of Bug #1334952 +++

+++ It's probably related to Bug #1328563  +++

Steps to Reproduce:

1a. on lithium surf to "28January2017 test showfor article" (link https://hwsfp35778.lithium.com/t5/Basic-Browsing/28January2017-test-showfor-article/ta-p/3) on Mac OS X Firefox 51 and Firefox 50.1 Android

OR 
1b. on kitsune, surf to:
https://support.mozilla.org/en-US/kb/01february2017-testing-osx-android-showfor

Expected Results:
1. only see Android content on Firefox Android AND
onlye see Mac OS X content on Mac OS X on both kitsune and lithium

Actual Results:

1a. On Lithium I erroneously see Android content on MBP 13" 2015 Mac OS X 10.11.6 Firefox 51.0.1
AND
on Android Firefox 50.1 , Pixel XL Android 7.1.1 I erroneously see Linux content

1b. On Kitsune I erroneously see
i) on FFMac and FFWindows you erroneously see Android Content
ii) on FFAndroid you erroneously see Windows content
iii) on FFiOS you erroneously see Android content

We believe this is a bug in showfor.js
https://github.com/mozilla/kitsune/blob/master/kitsune/sumo/static/sumo/js/showfor.js
:giorgos is this the right showfor to check?
https://github.com/mozilla/kitsune/blob/master/kitsune/sumo/static/sumo/js/showfor.js
Flags: needinfo?(giorgos)
:tyson where do I find the showfor.js in lithium again?
Flags: needinfo?(tyson.nunemacher)
(In reply to Roland Tanglao :rolandtanglao from comment #1)
> :giorgos is this the right showfor to check?
> https://github.com/mozilla/kitsune/blob/master/kitsune/sumo/static/sumo/js/
> showfor.js

Yes
Flags: needinfo?(giorgos)

Comment 4

9 months ago
Note that this is a useful CSS rule to see the showfor code:

.for[data-for]:before{content:"["attr(data-for)"]";color:#800000}
DIV.for[data-for]{display:block!important}
SPAN.for[data-for]{display:inline!important;color:#008000}

Updated

7 months ago
Component: Lithium Migration → Knowledge Base Software
Product: support.mozilla.org → support.mozilla.org - Lithium
Priority: -- → P1
unneedinfo'ing tyson because i believe he's not going to be involved in this going forward and other lithium staff will invovled
Flags: needinfo?(tyson.nunemacher)
Assignee: nobody → rtanglao

Comment 6

3 months ago
We aren't moving back to Lithium - see https://blog.mozilla.org/sumo/2017/06/28/important-platform-update/ so the Lithium portion of this bug is invalid. 

(In reply to (In reply to Roland Tanglao :rolandtanglao, :mohnkuchen, :adobo, :sinigang, :roland from comment #0)
  
> 1b. on kitsune, surf to:
> https://support.mozilla.org/en-US/kb/01february2017-testing-osx-android-showfor
> 
> Expected Results:
> 1. only see Android content on Firefox Android AND
> onlye see Mac OS X content on Mac OS X on both kitsune and lithium
> 
> Actual Results:
> <snip>
> 
> 1b. On Kitsune I erroneously see
> i) on FFMac and FFWindows you erroneously see Android Content
> ii) on FFAndroid you erroneously see Windows content
> iii) on FFiOS you erroneously see Android content
> 
> We believe this is a bug in showfor.js
> https://github.com/mozilla/kitsune/blob/master/kitsune/sumo/static/sumo/js/
> showfor.js


As for the Kitsune portion of this bug, Roland, can you revisit the article and test again? I checked https://support.mozilla.org/en-US/kb/01february2017-testing-osx-android-showfor and only Firefox was shown in the "Customize this article" picker. After I edited the article Description (which only had "Relevant to:" Firefox) and added "Relevant to:" Firefox for Android, the "Customize this article" picker shows both Firefox and Firefox for Android.  When I viewed the article on Windows, the Firefox for Android picker is unchecked and the Android content is not displayed.  

If there are still showfor issues on Kitsune then it would probably be better to file a new bug instead of keeping this one open and moving it to the support.mozilla.org product.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Flags: needinfo?(rtanglao)
Resolution: --- → INVALID
yes, i believe showfor is working on kitsune!
Flags: needinfo?(rtanglao)
You need to log in before you can comment on or make changes to this bug.