Cannot handle properly contacts without primary email address.

RESOLVED DUPLICATE of bug 248786

Status

RESOLVED DUPLICATE of bug 248786
17 years ago
13 years ago

People

(Reporter: fgomes, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From the user's point of view he/she may keep his/her contacts into Mozilla's
Address Book regardless if his/her contacts have or not email addresses.<br>
The user may be interested in keeping his/her contacts organizer and
categorized, regardless if his/her contacts have email addresses or not.

<p>
The problem arises when user creates many contacts without primary email address
and tries to organize his/her contacts into distribution lists. It seems strange
to organize contacts without email addresses into distribution lists? Not for
the user's point of view. He/She simply wants to *organize* or *categorize*
his/her contacts using the only tool Address Book offers to do this job.<br>

When user inserts such contact into a distribution list it seems it was not
inserted. In fact it is there, but user interface does not shows contacts
without email addresses. In the user's point of view Address Book should insert
and show contacts but should mark them with some special icon showing that
there's no email address in there and, of course, this contact cannot be
processed when sending email messages (but of course user can retrieve contact's
phone number, for instance).

<p>
If there are many contacts without email addresses and user continues to
organize his/her contacts, when user finishes and starts revisiting his/her
distribution lists... then a total mass becomes clear.

<p>
It seems Address Book uses primary email address as a key for indexing
components of distribution lists. As user have entered contacts without email
addresses, Address Book becomes confused because its indexing key has duplicated
values.

<p>
The only way to circunvent this problem is:<br>
1. Forget everything. You will lost your job and time. Remove all your
distribution lists.<br>
2. Update every contact without primary email address and insert a
**fake-non-duplicated** email address, for instance: null.john.smith@null.null.
This format is adequate so its possible to sort by primary email address and see
together all contacts without email addresses.<br>
3. Recreate your distribution lists.<br>
4. Reorganize and recategorize everything.<br>

<p>
**Note**<br>
Besides of these problems, I insist in using Address Book as my primary source
of contact information. This component is very very important and even can drive
more Mozilla acceptance between normal users. Microsoft have already detected
this importance and have improved "Contacts" very much.

Comment 1

17 years ago
Oops.  Should have added additional info:

This is happening on Linux also, in builds as new as 2002040808 (haven't checked
past that yet)

Comment 2

16 years ago
Buffy build 2002-10-15: Mac 10.1.3
Reproduced some of what was described.

Steps to reproduce:
1. Create 3 cards without an email address (i.e. First Name and Last Name)
a. Mike Smith
b. Mary Smith
c. David Smith

2. Create a list and close the list without adding any entries
3. Expand the address book in the directory pane so the list name appears 
4. Drag-n-drop each card onto the list

Actual Results: 
a. Select the list from the results pane and the bottom pane displays 
"First Name <>" (i.e. Mike<>).
b. Double click on the list and it only has one entry (i.e. Mike<>)
c. Select the list in the directory pane and it displays the card in the Results
pane for the last entry (i.e. David Smith). Then double click on the list and it
 displays "Mike<>" on the first address line.

Expected Results: The reporter would like a way for this to work. Maybe display
first and last name? 
Status: UNCONFIRMED → NEW
Ever confirmed: true
mass re-assign.
Assignee: racham → sspitzer

Comment 4

15 years ago
*** Bug 220401 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
*** Bug 221267 has been marked as a duplicate of this bug. ***
The addressbook is and remains a mess. Is anybody doing anything about it??? Do
you need a sponsor for this??? Name me one who is willing to imrove this please.
10 month have passed and nothing has been done about this problem. Instead i get
a meassage informing me this bug is a duplicate of another..is this all? I am
not in the mood of wasting nice words and lenghty descriptions here. I feel like
locked in. Does thunderbird handle this better - the product description has no
word about the addressbook. Will you please realize that the addressbook is an
important feature decisive for adopting to mozilla at all?
Product: Browser → Seamonkey

Updated

14 years ago
Assignee: sspitzer → mail

Comment 7

13 years ago
I agree to the previous writer, that the adressbook is far more important to users, than developers might think.

I have one more problem with it:

It is not possible to ad a contact to an distribution list, if the contacts e-mail address is simmilar to the address of another card. Oc course it sounds unlogical at first sight, to add two contact with the same address, but users request that often, as someone told before, people use the "lists" to sort contacts. So it can happen, that a user creates a card for "john doo" with the adress "john@doo.com". Than he creates a card für john doo's wife -> jane doo. Becouse she has not an email adrdress, he uses the address of "john doo". Next he wants to create a list calles "friends" an put both "doo's" in it, which is not possible, becouse its the same e-mail address!!!! :-(

I am not a programmer, so I cannot help with more than creating bugreports :-( But I hope that someone of the responsible persons see the importance of the addressbook, and the errors it has until today...

Cincerelly, Claus Berghammer

Comment 8

13 years ago
There are 5 adresses that are informed of changes to this bug id, but only two votes for it (the second is by me). So please, if developers schould take care of this, you should vote for this bug! Just open this case, and click on "Vote for this bug"!!!
This is the same as bug 248786, I'm duping to that one as it is more concise and it resides in core address book which is what this bug is.

*** This bug has been marked as a duplicate of 248786 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.