Suggestion for easier assignment of users to projects

RESOLVED DUPLICATE of bug 43618

Status

()

Bugzilla
Administration
--
enhancement
RESOLVED DUPLICATE of bug 43618
16 years ago
5 years ago

People

(Reporter: Stuart Meisel, Assigned: justdave)

Tracking

2.14
x86
Windows 2000

Details

(Reporter)

Description

16 years ago
I would like to see an easy to to assign lots of users to a project without 
having to do each user individually.

When a new project is initiated in Bugzilla, I define:
Project
Groups (If used)
Components
Milestones
Etc., etc., etc.

Then comes the fun part -- Assigning users to the project.  Right now, it seems 
that each user must be assigned to the project individually with rights given 
individually.  This is a problem when projects are more than 10 people, or when 
an entire company is to be assigned rights to project.

I was hoping that a more efficient way could be available:
For example,  One Idea is:
A drop down box with the projects listed.  
When you select a project, a list of user-types appear.  (A user type in this 
example would be a dummy or template user with certain rights assigned, such as 
CanConfirm and CanEdit)
When you select a user type, a list of users appear, with check boxes next to 
their email address. 

(This idea might require a Bugzilla administrator to pre-load user-types.) 

I am sure that you have even better ways.  And, if it is already in Bugzilla, 
please tell me how to use it.

The whole idea here is to have an ability to assign lots of users to projects 
with fewer steps.

Thank you.

Comment 1

13 years ago
This is really two things in one:
1) Request for the ability to assign users to groups en masse, or at least 
without having to edit each user individually
2) The 'user types' idea, so as to be able to categorize people and then assign 
membership to other groups based on these higher-level categories.

The second part has been fixed with the groups re-write of 2.18; hierarchical 
groups allows you to do almost exactly what was being requested here.

The first part is an almost exact duplicate of bug 43618. Since it's the only 
part of this remaining open, I'm going to dupe this bug to that one.

*** This bug has been marked as a duplicate of 43618 ***
Severity: normal → enhancement
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Component: Bugzilla-General → Administration
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.