Access keys in proxy dialog in preferences no longer work

RESOLVED DUPLICATE of bug 1194528

Status

()

RESOLVED DUPLICATE of bug 1194528
2 years ago
2 years ago

People

(Reporter: appa.g0dlike, Unassigned)

Tracking

({regression})

54 Branch
x86_64
All
regression
Points:
---

Firefox Tracking Flags

(firefox51 wontfix, firefox52 wontfix, firefox53 wontfix, firefox54 fix-optional)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8832947 [details]
Screenshot_of_Connection_Settings.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.124 Safari/537.36

Steps to reproduce:

1. Go to about:preferences#advanced
2. Click on the Network tab
3. Click on Settings (under Connection)
4. On the keyboard, enter the key combination Alt+m


Actual results:

Nothing.


Expected results:

When the key combination of Alt+m would be pressed (after Connection Settings dialog opens), the radio button for "Manual proxy configuration" should have been selected.
This goes for other keyboard shortcuts too which would select different options depending on the underlined letter.
(Reporter)

Comment 1

2 years ago
Last version where this was working as expected for me was 50.0.2
Keywords: regression
Whiteboard: keyboard shortcuts, settings, preferences
Does this reproduce in Firefox's safe mode and/or a new profile? https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems
Whiteboard: keyboard shortcuts, settings, preferences
(Reporter)

Comment 3

2 years ago
Yes, reproduced under safe mode and new profile.
(Reporter)

Updated

2 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Comment 4

2 years ago
I can reproduce this on Windows 10 with FF Nighlty 54.0a1(2017-02-03). I run mozregression and here is the pushlog:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=a6f67ab4a4ec4dd66f53c4b4423e5b8b63023388&tochange=dce857dd57e2d91ae4c6014cf21e93ef95e4dd36
Also in mozregression I have a commit message:  Bug 1282910 - Fix issuerOrganizationUnit property name in test_security-info-certificate.js. r=jsnajdr

Mgsudhanva do you have any idea about this? Thanks  

Note: I couldn't reproduce it on Mac 10.10.
Status: UNCONFIRMED → NEW
status-firefox51: --- → affected
status-firefox52: --- → affected
status-firefox53: --- → affected
status-firefox54: --- → affected
Component: Untriaged → Preferences
Ever confirmed: true
Flags: needinfo?(mgsudhanva)
OS: Linux → All
Version: 51 Branch → 54 Branch
This is a regression from Joseph Yeh — Bug 1036815 - Convert Advanced pane dialogs to be in-content. r=MattN  not the other bug.
Blocks: 1036815
Flags: needinfo?(MattN+bmo)
Flags: needinfo?(mgsudhanva)

Updated

2 years ago
Summary: Keyboard shortcuts in Preferences no longer work. → Access keys in proxy dialog in preferences no longer work

Comment 6

2 years ago
Access keys don't work for me at all in about:preferences (Nightly on Windows 10).
(In reply to AppAraat from comment #0)
> When the key combination of Alt+m would be pressed (after Connection
> Settings dialog opens), the radio button for "Manual proxy configuration"
> should have been selected.
In the new Preferences, you have to press Alt + Shift + <letter>. This is bug 1194528.
Can you test if Alt + Shift + M selects the item you want?

(In reply to Steffen Wilberg from comment #6)
> Access keys don't work for me at all in about:preferences (Nightly on
> Windows 10).
Do you use Alt + Shift + <letter>? Works here on Windows 8.1 + Nightly 54.0a1 20170205030206. Please file a new bug (this one will get closed if that works for the reporter).
Flags: needinfo?(MattN+bmo) → needinfo?(appa.g0dlike)

Comment 8

2 years ago
Right, Alt+Shift+letter works for me in about:preferences, including subdialogs.
(Reporter)

Comment 9

2 years ago
(In reply to Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) from comment #7)
> Can you test if Alt + Shift + M selects the item you want?

Yes, I can confirm that Alt + Shift + M selects the item I want.
Furthermore, I can confirm that other access keys also work with the Alt + Shift key combination.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1194528
Flags: needinfo?(appa.g0dlike)
Mark 51 won't fix as there is no plan to ship 51 do release right now.
status-firefox51: affected → wontfix
Also too late to fix in 53. But, I did notice there may be a workaround mentioned in https://bugzilla.mozilla.org/show_bug.cgi?id=1194528#c1 . Hope that helps for now.
status-firefox52: affected → wontfix
status-firefox53: affected → wontfix
status-firefox54: affected → fix-optional
You need to log in before you can comment on or make changes to this bug.