Status

Firefox Build System
General
RESOLVED DUPLICATE of bug 1298600
2 years ago
5 months ago

People

(Reporter: rillian, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

I noticed working on bug 1284816 that while configure checks for cargo, it doesn't stop the build if it isn't found, leaving `force-cargo-library-build` to fail mysteriously with

> env: ‘:’: No such file or directory

We should print an error the same way `rust_compiler` does if rustc is missing.
One of Nathan's patches in bug 1298600 fixes this.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1298600
(Reporter)

Comment 2

2 years ago
Thanks Ted, forgot that was still outstanding.

Updated

5 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.