All users were logged out of Bugzilla on October 13th, 2018

Dialog buttons in bad colors in Default Theme

RESOLVED INVALID

Status

RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: jwjr, Unassigned)

Tracking

SeaMonkey 2.48 Branch
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:51.0) Gecko/20100101 Firefox/51.0 SeaMonkey/2.48
Build ID: 20170129191635

Steps to reproduce:

Use SeaMonkey 2.48 with Default Theme


Actual results:

The "default" button for any dialog is displayed with white text on light grey background - barely readable. Non-default buttons are displayed normally, but turn to white text on light grey background when moused over.


Expected results:

Button texts should always be legible.
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86
Could you attach a screenshot.
(Reporter)

Comment 2

2 years ago
Created attachment 8833028 [details]
Screenshot of bottom of Preferences dialog
Created attachment 8833032 [details]
Capture.PNG

I am not seeing this in either a VM or real hardware. Neither 2.48 nor 2.51a1 are affected.

From top to bottom:
Windows Classic
Windows 7 Basic
Windows Aero

Could you try and check with a standard Windows 7 theme and/or also with a new test profile or in safe mode.

If Intel video try to switch of hardware acceleration and check if you have the latest video drivers.
(Reporter)

Comment 4

2 years ago
With Windows Classic and Windows 7 Basic themes, I do _not_ see the problem. The problem occurs on _all_ of the standard Aero themes.

Safe mode makes no difference. Video hardware is AMD Radeon HD 8350, latest drivers.
Hmm might be a hardware or driver problem.

Do you run the Crimson drivers?

> Crimson Edition 16.2.1 Beta
> http://support.amd.com/de-de/download/desktop/legacy?product=legacy3&os=Windows+7+-+32

Could you try a Firefox 51 builds and see if the problem is also visible there. I this case the bug should be moved to a Gecko component. Not away of anything in SeaMonkey source code which could cause this.
(Reporter)

Comment 6

2 years ago
I am not running the Crimson drivers.

The problem does not occur for me with Firefox.

The problem did not occur for me in SeaMonkey 2.47, but appeared in 2.48.
(Reporter)

Comment 7

2 years ago
After a few more hours of swapping hardware and software, the problem appears to be on my end. I'm marking this RESOLVED.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
Great. Were you able to track it to a specific component or was it just the healing hand reseating the card?
(Reporter)

Comment 9

2 years ago
It was a Compatibility setting: "Disable visual themes" was checked. <facepalm> No one has _any_ idea who did it, of course.
You need to log in before you can comment on or make changes to this bug.