Closed Bug 1336217 Opened 5 years ago Closed 5 years ago

drop conditional inclusion of some OSX skin files because it's always true

Categories

(Firefox :: Theme, defect)

defect
Not set
trivial

Tracking

()

VERIFIED FIXED
Firefox 54
Tracking Status
firefox54 --- verified

People

(Reporter: aryx, Assigned: aryx)

References

Details

(Whiteboard: [bugday-20170426])

Attachments

(1 file)

browser/themes/osx/jar.mn

% override chrome://browser/skin/toolbarbutton-dropmarker.png              chrome://browser/skin/lion/toolbarbutton-dropmarker.png                 os=Darwin osversion>=10.7
% override chrome://browser/skin/tabbrowser/alltabs-box-bkgnd-icon.png     chrome://browser/skin/lion/tabbrowser/alltabs-box-bkgnd-icon.png        os=Darwin osversion>=10.7
% override chrome://browser/skin/places/toolbar.png                        chrome://browser/skin/lion/places/toolbar.png                           os=Darwin osversion>=10.7

osversion>=10.7 can be dropped.
Comment on attachment 8833080 [details]
Bug 1336217 - drop conditional inclusion of some OSX skin files because it's always true and drop unused images.

https://reviewboard.mozilla.org/r/109302/#review110416

::: browser/themes/osx/jar.mn:202
(Diff revision 1)
>  [extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}] chrome.jar:
>  % override chrome://browser/skin/feeds/audioFeedIcon.png                   chrome://browser/skin/feeds/feedIcon.png
>  % override chrome://browser/skin/feeds/audioFeedIcon16.png                 chrome://browser/skin/feeds/feedIcon16.png
>  % override chrome://browser/skin/feeds/videoFeedIcon.png                   chrome://browser/skin/feeds/feedIcon.png
>  % override chrome://browser/skin/feeds/videoFeedIcon16.png                 chrome://browser/skin/feeds/feedIcon16.png
> -% override chrome://browser/skin/toolbarbutton-dropmarker.png              chrome://browser/skin/lion/toolbarbutton-dropmarker.png                 os=Darwin osversion>=10.7
> +% override chrome://browser/skin/toolbarbutton-dropmarker.png              chrome://browser/skin/lion/toolbarbutton-dropmarker.png                 os=Darwin

We should remove these three overrides and move e.g. lion/toolbarbutton-dropmarker.png to replace the old and unused toolbarbutton-dropmarker.png.
Attachment #8833080 - Flags: review?(dao+bmo) → review-
Duplicate of this bug: 1276538
Comment on attachment 8833080 [details]
Bug 1336217 - drop conditional inclusion of some OSX skin files because it's always true and drop unused images.

https://reviewboard.mozilla.org/r/109302/#review111464

Thanks!
Attachment #8833080 - Flags: review?(dao+bmo) → review+
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/1f2a998647d7
drop conditional inclusion of some OSX skin files because it's always true and drop unused images. r=dao
https://hg.mozilla.org/mozilla-central/rev/1f2a998647d7
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 54
I have reproduced this issue on Firefox nightly according to (2017-02-02)

Fixing bug is verified on Latest Developer Edition-- Build ID: ( 20170427004028 ),User Agent: Mozilla/5.0 (Windows NT 6.1; rv:54.0) Gecko/20100101 Firefox/54.0

Tested OS-- windows7 32bit
 [bugday-20170426]
Status: RESOLVED → VERIFIED
Whiteboard: [bugday-20170426]
(In reply to Saheda Reza [:Antora] from comment #8)
> Fixing bug is verified on Latest Developer Edition-- Build ID: (
> 20170427004028 ),User Agent: Mozilla/5.0 (Windows NT 6.1; rv:54.0)
> Gecko/20100101 Firefox/54.0
These changes don't affect Windows builds but only the Mac ones.
(In reply to Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) from comment #9)
> (In reply to Saheda Reza [:Antora] from comment #8)
> > Fixing bug is verified on Latest Developer Edition-- Build ID: (
> > 20170427004028 ),User Agent: Mozilla/5.0 (Windows NT 6.1; rv:54.0)
> > Gecko/20100101 Firefox/54.0
> These changes don't affect Windows builds but only the Mac ones.

yes I got it. I just checked out the update file from windows... next time I must be carefull about this.
 thank you.
You need to log in before you can comment on or make changes to this bug.