Intermittent /workers/interfaces.worker.html | WorkerGlobalScope interface: operation close() - assert_own_property: interface prototype object missing non-static operation expected property "close" missing

RESOLVED DUPLICATE of bug 1336043

Status

()

Core
DOM: Workers
RESOLVED DUPLICATE of bug 1336043
a year ago
a year ago

People

(Reporter: Treeherder Bug Filer, Assigned: baku)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Regression from your recent worker change?
Flags: needinfo?(amarchesini)
(Assignee)

Comment 2

a year ago
Created attachment 8833354 [details] [diff] [review]
interface.patch
Assignee: nobody → amarchesini
Flags: needinfo?(amarchesini)
Attachment #8833354 - Flags: review?(Ms2ger)
Can you please explain why the test fails intermittently, and how this patch fixes that?

Also, point to the canonical standard at <https://dom.spec.whatwg.org/>.
(Assignee)

Comment 4

a year ago
> Can you please explain why the test fails intermittently, and how this patch
> fixes that?

The patch updates the WPT with a more recent interface. Probably it's better to have a separate bug for it.
Comment on attachment 8833354 [details] [diff] [review]
interface.patch

Unrelated to this bug afaict.
Attachment #8833354 - Flags: review?(Ms2ger) → review-
(Assignee)

Comment 6

a year ago
It seems that this bug is already fixed. Can we close it?
Flags: needinfo?(cbook)
yeah sure, fine for me
Flags: needinfo?(cbook)
(Assignee)

Comment 8

a year ago
I'm not sure if this is the correct duplicate bug.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1336043
You need to log in before you can comment on or make changes to this bug.